3.2.5 can't count decks?

I have a module I have been using.

It uses a “Set Global Property” that Sets the variable value directly to “($DrawDeck_numPieces$)” (no quotes) and displays this variable for all to see in their private windows.

Now with 3.2.5, it can no longer read _numPieces. I uninstalled 3.2.5, went back to 3.2.2 (the last version I had) and it worked.

Thought you might want to know this.


  • Model (HP Elitebook)
  • Operating System (Win 7)
  • CPU (Not sure what this means)
  • Memory (8.00 GB RAM)
  • Video Card
  • Vassal version. (3.2.5 – but it works just fine on 3.2.4)
  • Java version. (1.7.0_21)
  • Vassal module name and version (It’s unreleased, but I have the instructions)
  • Exactly what steps are required to reproduce your problem. If you are reporting on a problem that you can’t reproduce consistently, include as much information as possible about what you were doing right before the error occurred.
  1. I click a “Draw Card” action button.
  2. In the private window, it tells how many cards is in the draw deck. I call this variable “RomeDrawSize”
  3. The action button triggers a Global Key Command that sends CTRL 2 to BasicName==“HiddenCounterCalibrate” located on the main window where the draw deck is located. The draw deck is called ‘RomanDraw’. (no quotes)
  4. HiddenCounterCalibrate has a Set Global Property that sets Global Property Name “RomeDrawSize” (no quotes), so that when it sees CTRL 2, it sets the value directly equal to “{$RomanDraw_numPieces$}” (again, no quotes).
  5. RomanDraw DOES have the “Perform counting of property expressions?” box checked.

And like I said, when I uninstalled 3.2.5 and went back to my last version (3.2.2), it worked. My oppenent uninstalled 3.2.5 because he got the same error, and he went back to his last version (3.2.4) and it worked for both of us. I don’t know his specifications.

I posted it on a different forum first and the answer is there. 3.2.6 fixes this.

More info here: