3.5.3 LOS

Playing Heroes in Defiance. Files saved in 3.5.3. LOS line cannot be turned off. Worked ok in previous versions.

I have verified this bug still exists in the current 3.5.4 build and opened ticket 14256 for it – vassalengine.org/tracker/sho … i?id=14256


No, what you are seeing worked exactly the same in previous versions, back to and including 3.4.

This issue happens in a module that displays the LOS thread to other players when you start a LOS thread when creating a log file, then close the log file while the LOS is still active, without finalising and clearing it. The Log file does not contain the Command to finish the LOS.

Vassal is just doing exactly what you requested. You can’t create or change a LOS once another player has started a LOS, this is just the same.

The work-around to resolve the issue is to save the same, quit and restart Vassal, then reload the save game. This will re-initialise the LOS component.

I am not sure how to approach fixing this.


After a bit of a chat among the Developers, I think the simplest solution is to have a subsequent press of the LOS button when a LOS is currently active, to close, clear and re-initialise the active LOS.

In the case of shared LOS threads (Other players can see), this would allow any player to clear an active LOS at any time.