3.5.4 Chess Clock Reset doesn´t work

Hi all!

The new “Reset Clock” doesn´t seem to work.

When you enable “Allow manual reset of Chess Clock timers” checkbox, the module don´t save the changes. When you enter again in the properties of the Chess Clock the checkbox is disabled again.

Uh oh! How did that happen?!?!

Please go here and try out the test build marked 14284 (presently at the top but depending on when you see this it may have scrolled down the page or onto a later page) – vassalengine.org/builds/

We can have it fixed for 3.5.5 but please give this a thorough test and see if it is doing what you need for your module.


Hi Brian.

I ve just tried what you tell me:

  1. dowload 14284
  2. installed the Vassal 3.5.5 Snapshot.
  3. Enable the Chess Clock Reset, save and exe. my module

but the problem remains.

(are these the steps you wanted me to do? Sorry but its my first time)

When I´m editing the module and enable the checkbox “Allow…” (Step 1 image) OK the window and the clock reset works properly. (step 2 image). Save the module.

When you enter into the game, then the Reset button it´s not longer there (step 3 image)

Okay thanks – I have pushed an additional fix to the branch. As soon as the NEW set of 14284’s appears, try them please?


The build to try is currently about halfway down the page of vassalengine.org/builds

Or if you’re on windows, the direct link is: vassalengine.org/builds/build/50247111

Ok, I understand that you have uploaded a new version of the upgrade.

If so, i installed the link that you posted and it doesn´t work yet.

Hi - when I tested the branch myself it seems to work right:
(1) I added Chess Clocks to a module
(2) I set the “allow reset” checkbox on the Chess Clock Control item
(3) I saved the module out
(4) I launched the module to “play” it
(5) I started a clock
(6) I right clicked on the clock – the “Reset” option was there
(7) I selected the reset option, and the clock reset itself to 0.

Which part wasn’t working? I want to make sure you got the right build & installed it and made sure you were running that version of Vassal.

Be sure you download and install the most recent 14284 builds from vassalengine.org/builds
Presently those are down near the bottom of the first page, but by the time you see this they may be on the
second page. Note the snapshot numbers and dates listed:
VASSAL-3.5.5-SNAPSHOT-11cbe37-14284-windows-64.exe 2021-03-29 16:07:09
VASSAL-3.5.5-SNAPSHOT-11cbe37-14284-windows-32.exe 2021-03-29 16:07:09
VASSAL-3.5.5-SNAPSHOT-11cbe37-14284-other.zip 2021-03-29 16:07:09
VASSAL-3.5.5-SNAPSHOT-11cbe37-14284-macos.dmg 2021-03-29 16:07:09


Hi Brian. Here are the steps that I´ve just follow


I tried to create a new module following your steps but it didn´t work.

I uninstalled Vassal SnapShot and reinstalling again with the 14284 (downloaded again) but the result remains

I will try to install de Snapshot 14284 in another laptop this afternoon and i´ll test it

I´ve just installed the Vassal Snapshot 14284 in another laptop and it doesn´t work. Both laptos are Windows x64.

Its like if the “Allow manual reset…” checkbox won´t stay fixed when i press the Ok button, and Vassal don´t save that change


Whoops, I apologize – when I checked in the most recent changes I didn’t realize that Joel had already merged my branch, and so the automated build maker didn’t make a new build with my “updated changes”.

Please try with THESE builds, that have just gone up? Brian

VASSAL-3.5.5-SNAPSHOT-b8194f8-14284-windows-64.exe 2021-03-31 16:47:45
VASSAL-3.5.5-SNAPSHOT-b8194f8-14284-windows-32.exe 2021-03-31 16:47:45
VASSAL-3.5.5-SNAPSHOT-b8194f8-14284-other.zip 2021-03-31 16:47:45
VASSAL-3.5.5-SNAPSHOT-b8194f8-14284-macos.dmg 2021-03-31 16:47:44
VASSAL-3.5.5-SNAPSHOT-b8194f8-14284-linux.bz2 2021-03-31 16:47:44
VASSAL-3.5.5-SNAPSHOT-b8194f8-14284.sha256 2021-03-31 16:47:44

IT WORKS BRIAN!!! :smiley: :smiley: :smiley:

Is this Snapshot fully operative to play with my friends if all the group have the same snapshot version? (so we wouldn’t have to wait for 3.5.5 release)

Well, what I would probably suggest is making a backup of your module (before ever saving it with this snapshot) and keep that to one side.

And then, sure, make a version with this snapshot where you turn on the rest function, and play the module with your friends with everybody using this version, and you should basically be fine.

Once 3.5.5 comes out, obviously upgrade it (and the module) to that. And just in case 3.5.5 doesn’t like something about the format that this snapshot writes, you’ll have the backup. I mean probably everything will “just be fine”. But intermediate versions always make me nervous! :slight_smile:


p.s. Hooray!!!

Ok!! Thank you very much!