3.5.4 Problems

I found two problems with 3.5.4.

First some background.
In an earlier report (3.5.3 and earlier), I had a problem in live games where if I watched my opponent press a button to send all cards from a discard pile to the main deck and reshuffle the main deck (two hot keys that the button “pressed”), the deck became corrupted as I saw it. Cards in the main deck became face up, and some cards disappeared, but for me only. She saw everything normal. If I resynched, the problem disappeared until the next time. This happened in two modules.

To help test, I stripped a module down to bare bones. Tonight we would play live, but just before we did this, we both upgraded to 3.5.4, and we ran the decktest module to ensure we still had the problem, but something different happened. When she pressed the button, nothing happened. The button would not respond to her presses. When I pressed the button, it worked as it should. There is nothing in the code that is tied to a particular player. I have a test vmod to demonstrate.

We then abandoned “decktest” and played the game. As with decktest, her “restore deck” button would not function for her. She then tried pressing my deck’s restore button, and it didn’t work for her either. For me, everything worked normally, so in our game, I had to press her deck’s restore button for her. We never got to the problem I was originally trying to test.

Problem 2. She complained that her main window kept flying over to the extreme right side on its own. It turned I had my personal window open on the right side of the screen, and whenever I right-clicked a particular piece in my window and selected a particular command, then her screen would fly to the right as if vassal decided to “center on opponent’s move.” Except I was right-clicking a piece in a different window, not the window where it was happening. I told her to deselect “center on opponent’s move” in her preferences, and with that the problem disappeared. Note the problem didn’t happen for any piece I selected on my map, only this one particular piece and one particular command. This never happened before 3.5.4.

Hi Stan - the deck / global Hotkey Issues are the subject of a handful of problem tickets that stemmed originally from work on 14225. Most seem fixed now in the dev versions. At the moment, there is one outstanding issue (14301) which arose following the last fix.

You can review my tracker here which itemises the problem tickets and pass/fail results against test cases.

Joel (ukelman) has released a new build page here, any testing on your own module would be appreciated if you can spare the time.

I can’t comment on your problem #2; I take it is unrelated unless I’ve misunderstood.


I think I understand more about my problem #2. When I right clicked on a piece in my window, that piece drew a card from a deck, which was on the right side of the main window. She had “center on opponent’s move” enabled, so when my piece grabbed a card from that deck, vassal recognized it as a move on the right side of the main window and so centered on the deck. Perhaps this is normal behavior, not a bug, but it surprised me. Deselecting the centering option fixed it.

Reviewing your links, I remember some of those reports. When f saw them, I thought they were probably related to mine. My summary is that in live games, vassal is not properly synchronizing deck hot keys. At least that is what it looks like in my cases.

I can test new versions, but it’s awkward for me because I can do it only when my partner and I are online and she cooperates. That’s not hard, but I can’t just hop to it. I see Joel’s list, and I assume I should test the top-most one? Is it worthwhile for me to do now, or should I wait? We plan to play live tonight, so I hope to get a quick test in of my bare-bones vmod.

Builds from the master branch don’t have branch labels in their names. I.e., they will have names of the form “VASSAL-3.5.4-SNAPSHOT-hhhhhhh-windows-64.exe” for 64-bit Windows, say.Try whatever build form the master branch is newest (but tell us which one you tried).

First off, I didn’t know that I could run two vassal apps from one computer and through the Vassal server. It seems I was wrong.

First I tried running my decktest vmod with two users through the server using 3.5.4. As I mentioned above, the person who joined the game could not get a button to work that sent discards to the main deck and shuffled them. I reproduced the problem just now with 3.5.4.

I then installed VASSAL-3.5.5-SNAPSHOT-b4b7d8d-windows-64.exe (with some interference from Avast*). When I ran the same test again, it worked fine as it should. I also did not see my earlier report that this action corrupted the deck from one player’s viewpoint. Excellent.

Of course, this is not a comprehensive test. I need to check it out with real vmods, but the results are encouraging.

  • My first attempt to run the snapshot failed because of Avast interference that I did not see. It caused a crash report to be submitted. For those who look at such things, please ignore.

Are all the problems here resolved as of 3.5.5?

All my tests worked even across the server, but I haven’t had a chance to play online yet with my regular partner. I would be very surprised though if it didn’t work.