3.5.4 uncaught exception

I’m getting consistent errors with 3.5.4. However, I’ve yet to see any actual bad behavior from it. I just get an ‘eek!’ message.

Letting Vassal send a bug report on it’s own fails (I don’t think I’ve ever seen that work, not just with this).

Steps to reproduce:

  1. open log file
  2. start a new log
  3. start stepping through the original log, recording reactions, etc.
  4. when you hit the end of the original log, the error box comes up

I’ve attached the log file, which took some doing as it doesn’t natively have a regular extension, and the forum software doesn’t allow *.4 attachments, and you can’t just copy and paste because the text is too long for a forum post…

How long has this been happening? That’s more worrying than the bug you’re reporting.

Try the VASSAL-3.5.5-SNAPSHOT-5b45c59 test build: vassalengine.org/builds/

Does that resolve the problem?

I don’t often have cause to need the function, but I don’t recall the last time the report function worked.

…Okay, that snapshot seems to resolve the reporting issue.

Joel,
This is the bug 14296 I filed yesterday.
vassalengine.org/tracker/sho … i?id=14296

I did not debug the code, but I am pretty sure it occurs when you keep the PgDown pressed to fast forward a log to its end.
Doing that might fill a buffer of unprocessed PgDown after the log is completed.

YOu can see that not occurring if you play the log slowly to the end.

What makes you think it doesn’t work?

We’ve merged the fix for 14296. Any non-branch build from d4e53e2 onward should have the fix.

vassalengine.org/builds/

There have been rare occasions when it’s thrown an error over the years, and I’ve hit the ‘report bug’ function… and it generally fails in my memory.

As far as the error reported… SNAPSHOT-b4b7d8d fixes it. I was a little surprised as Claudio’s diagnosis was definitely off, as I step through a log one action at a time, seeing what my opponent is doing, and not racing through it, and it gave the exception/bug with a single keypress.

…Though, just actually checked that case too, and no problems with racing through a log while recording one.

Thus spake Rindis:

What makes you think it doesn’t work?

There have been rare occasions when it’s thrown an error over the years,
and I’ve hit the ‘report bug’ function… and it generally fails in my
memory.

So you didn’t have any particular reason to think it failed in this case?


J.

Ah, why the bug reporting was failing. No, no idea at all why it should happen.

Or, if you mean why I thought it was failing, it was because the Vassal dialog said it failed.

That’s what I wanted to know.

This is your bug report: vassalengine.org/tracker/sho … i?id=14298

The attached errorLog is identical to the one you posted here—so I’m certain the report did not fail, even if the dialog told you that it did.

The next time this happens, would you take a screenshot of the message telling you that the report failed? Or, alternatively, can you tell me any of the text which was in the message?

Interesting, this happens to me most if not all of the time and I assumed that the bug reports weren’t getting through. Sometimes I will copy the dump and post an error report and sometimes I don’t.

The report, if it is the same one, is simply the Vassal “eeeek” box updating to inform you that the bug report didn’t get through and please email it in manually (with the dump still available in the window).

That’s the one. I purposefully tripped this bug off to get the window:

Would you please try the VASSAL-3.5.6-SNAPSHOT-780a505-report_fail build, here,

vassalengine.org/builds/

and post the errorLog after triggering a bug report dialog that claims to be failed? There should be some additional logging in that build to help us determine what’s going wrong.

Well, the bug I reported on here was fixed in SNAPSHOT-b4b7d8d, so that doesn’t cause an error window any more. Thankfully, I remembered another one I ran across:
Vassal seems to be automatically generating a ‘Player Sides’ component for a module, even if there’s no intention of ever using player sides in a module. Deleting that component and then starting a new game generates an uncaught exception error.

I believe the test build “14351” corrects this problem - thanks for the repro!

Just missed the 3.5.5 release, but it will be in 3.5.6 or 3.6.0 as appropriate.

Brian

I believe we’ve fixed the bug reporting problem in VASSAL-3.5.6-SNAPSHOT-0c5adab. A build should appear soon.

vassalengine.org/builds/