3.5 Beta 1 loses the descriptions of Global Key Commands

Just tried 3.5 beta 1; as soon as I open a Global Key Command (or the Startup Global Key Command), its description disappears. If I then save the module and reload, the description says “Do The Thing” until I open it, and then it goes blank again. I’m on Linux, but my friend on Windows 10 says the same happens to him.

Similar problem for Deck Global Key Commands: Once I open the DGKC, the “Menu command” entry is blanked out. If I run the module before loading it in the editor, the menu entries are still there, but once I’ve loaded the module in the editor, they all lose their text.

Thanks, I have passed that on to Brian.

vassalengine.org/tracker/sho … i?id=13823

Whoopsiepoop! I have pushed PR 619 which fixes the problem. Thanks! Fix should be in “beta 2” (or upcoming test builds)

Try VASSAL-3.5.0-SNAPSHOT-db7ecdc7e, available here:

vassalengine.org/~uckelman/tmp/

This build includes a fix for the bug you’ve reported.

I can confirm that this build fixes this particular problem (including the related Deck GKC problem).