3 problems (3.5.3)

I have encountered 3 problems.

  1. I have a deck of cards that never shuffles. If I send a GKC that sends some card (e.g. 4 cards) to a non-deck location, Vassal removes the (4) cards from the bottom of the deck and not from the top. I can submit a simple test module if needed.

  2. This is a repeat of a problem I reported but no one responded to. ( don’t know if it’s been addressed in the next version.) The controls for map Layers (e.g. “de-activate a layer”) are all screwed up. Imagine you enter an elevator, and when you press “3”, you go to “10” instead. Pressing “5” might take you to “1”. The assignments are consistent but all wrong. In the layer controls, the labels for the controls are wrong. For anyone who needs to use layer controls now, here’s what you must do:
    You want to de-activate a layer? Choose “toggle between active and inactive” instead.
    You want to toggle? Choose “reset” instead.
    You want to activate a layer? Choose “de-activate” instead.
    You want to reset all layers? Choose “activate” instead.
    There are a couple other options, but I never use them, so I don’t know their current state.

  3. This next one really bothers me. I’ve reported it, but no one responded. My opponent and I are playing a live game online. It’s a deck builder, so we each have our own face-down deck and face-up discard piles in our own public windows. I have her window open. She empties her deck, and she presses a button that sends the discards back to her deck and shuffles them. Everything is normal for her, but I now see a face-up deck. Sometimes cards are missing so sometimes she’s drawing cards from what I see as an empty deck. I saved the game, and when I loaded it offline later, I discovered when I hovered over her wrongly face-up deck, mouseover shows me her entire deck when I should see only one card.

I can fix it by re-synching to her, but that sometimes has caused problems. If she has my window open when I recreate my deck, she sees my deck as corrupted, and my resynching corrupts my deck so my cards are face-up to me. I think somehow the synch process in live play is not handling deck hot keys properly. This has now happened in two different modules.

This one is tough for me to characterize because it happens only in live online games. I suppose though I should try it out via vlogs, and I might be able to create a vsav file from a test vmod. And it may not happen if I’m not watching her deck. Don’t know.

#3 sounds very familiar… see Bugzilla record 14225.

See what you think.

I assume that you are using the deck HotKey to re-shuffle as that is what it is for. A more reliable alternative is to put a “Return to Deck” trait on each card and use a Global Key Command to trigger that trait when you want to do the shuffle. It may be slower, perhaps not noticeably.


Hi Stan,

  1. We have reproduced this issue, Brian is looking into it. There is a problem if you have turned any of the Fast-Match options on, it is dealing cards from the bottom of the Deck instead of the top.

  2. I will try and have a look at this issue now.

  3. The process of ‘syncing’ between different clients during online play using exactly the same processes as ‘syncing’ via vlogs, so you should be able to reproduce this using vlogs and changing your password to swap between sides. We do not have the resources to reproduce every bug that is reported, especially the more obscure like this one. If you can create a vlog that reproduces the problem, with known passworded sides, that will give us a chance to investigate.


That report is rather complex, but it probably is related. I’m trying to distill it to a simpler case. My guess is hot keys on decks aren’t being synchronized properly.

I’m puzzled by your alternative solution to the hot key shuffle, which I do. How does a return to deck randomize it?

Regarding #1, I’m glad you reproduced it. Yes, I did use the fast-match option with a deck==“deck name.” Actually, I also had a problem with it not doing the full number of fixed commands on a deck, but I couldn’t reproduce it, but I did notice this one while I was checking it. I have a simple test vmod if he needs it.

#2 is bizarre. The dialogue boxes have the proper additional arguments for what they are supposed to do, but the labels are wrong. For example, a reset does not need a list of layers, and the wrong option that does the reset does not ask for layers. It as if someone pasted stickers over the top of the option names. I can’t fathom how this could have happened.

For #3, I will run some tests using vlogs to see if I can simplify it further. I suspect as I said above that vassal is not synchronizing certain deck hot keys, but I don’t know if it is just re-shufffle or more than just that. The problem is certainly changing the deck’s characteristics. I’ll experiment and see if I can provide better information. Thanks for looking at these so quickly.

Hi Stan - I have found and fixed #1.

A test build will appear here: github.com/vassalengine/vassal/ … /677736827
(NOTE you will need to have a github account and be logged into it to receive live links to the downloadable test versions)

Let me know how that works for you. Meanwhile Brent is checking into #2 and #3 (please continue to follow up with any test-modules, etc that he has requested)


I am relying on randomization at card draw time. From the Deck “help”…

“Re-shuffle: If set to Never then cards remain in their original order; cards are drawn from and added to the top. If set to Always then cards are always drawn randomly from the deck. If set to Via right-click menu then a Shuffle entry is added to the Deck’s right-click context menu.”

That’s correct. Cards in a Deck always stay in the same order and randomization is always handled at card draw time, unless you specifically use the ‘Shuffle’ right-click option which will randomly re-order the cards in the Deck.

Oh, sure, but I can’t always do that. I have actions that put cards on the top (or bottom) of a deck (as an example) so on the fly reshuffling is out.

The always-reshuffle decks were working fine with Fast Match, but for “never reshuffle” and “manual reshuffle” decks like the one you described, it was “dealing from the bottom”. That test build I posted a few messages up should clear up that problem.

Thanks Brian. I will check it out tomorrow.

The “dealing from the deck bottom” problem is fixed. Thanks, Brian. As for the “corrupted deck during live play,” last night we played live (the game CloudAge). We purposely tried to get the failure, and to my chagrin, it didn’t happen! Clearly there is some trigger I’m missing. I have the day off, so today I will spend some time trying to isolate the problem, and I will report if I find anything new or interesting.

@Stan - re issue #3, I am trying to help narrow down the problem for the devs.
Would you mind sharing that deck building module or some distilled version that still has the problem ?
Also, did you use this module in the same way in previous Vassal releases without issue ? How far back ?


Thanks for the interest. I’ve spent a little time trying to narrow down the problem, and I’ve been unable to recreate it. I suspect something I don’t see triggers it, but I don’t know yet what that is. I’ve tried making a simplified version and observing via vlogs, but no luck. It works as expected, no failure. It’s a bit embarrassing actually. Yes, I could give you a module, but I’m afraid you too would not see a problem. Instead, I think you should let this one go until I can uncover more information—and maybe recreate the problem reliably.