Ambush: removal of event markers

Apologies if this has been answered before (I couldn’t find any reference to it using search).

I’ve just started playing Ambush using the Vassal module. When the condition changes you need to remove all the “event markers”. So I clicked on the “remove all event markers” button. Unfortunately everything then disappeared. I was left without any markers on the map (map A). Clicking undo did bring everything back (including event markers). I tried to right click on an event marker to see if I could delete them individually but right clicking did not bring up any options. Have I missed something simple?

Any help greatly appreciated. Thanks

That sounds like it’s a module issue in that the “event markers” should be tagged with a keyword and the “remove all event markers” should be coded to only remove markers with that keyword.

My best suggestion would be to contact the module designer and inform them of the bug. To do that, log into the module wiki and go to the module page. The designer’s name should provide an E-mail link or PM them.

thanks, I’ll try that


I realize this is an old post, but I’m having the same issue. The designer “madorosh” doesn’t seem to have an email address. I wish my VASSAL-fu was good enough to fix this as it doesn’t seem to be too difficult, but it would be great to be able to have it updates.



Email addresses will only display if you are logged into the wiki. In this case, the listed email address is:

So I’m using VASSAL 3.2.15 on a Mac and figured out how to get this to work.

In the Module Library screen right click on Ambush → Edit Module
Open the “Playing Surface [Map Window]” folder
Double click “Remove Event Markers [Global Key Command]”
In the “Matching properties:” box, enter: PieceID=26
Click OK
Save the Module

Worked for me. I’m no programmer, so I probably can’t help too much otherwise, but hopefully this works for you as well.

  • David