Area of Effect trait

Using VASSAL 3.0.17. When I give a piece the Area of Effect trait it works fine on a certain area of the map(with hexgrid), however when the piece is created or moved pass a certain hexrow(or column), the “shade” is no longer visable. EX: hex 0421, ok…hex 0422, not seen. Any help would be appreciated.

Please post a link to your module.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Thanks for the reply. How do I post a link?

I need to download your module to test it. You can email it to me at b.easton at exemail.com.au

B.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Unfortunately, the mod size is too big for e-mail(58Mb at this time). I think it’s probably a mem issue. I have 3 gigs of mem, but the prog doesn’t like the increase higher than 1054 at this time. The module is called Europa from GRD/HMS. The Europa Game Series is broken into separate game modules to cover WW2 in Europe from Skandinavia to Eritrea and Morocco to the Urals. At 16 miles per hex, it’s a BIG map for the Grand Europa Campaign Game(about 8’x8’ of actual map space). It’ll be a while before it’s completed, so by the time it’s done maybe there will be a system to handle it. Thanks much for your help, though.

Why are you using such large images? Maybe shrink them down and you’ll be able to run the module smoothly ::slight_smile:

The images aren’t any larger than any other vassal module, just the overall scale.

Without reviewing your module, I cannot help you.

B.

That’s ok, it’s not a critical part, thanks anyway.

Thus spake “Luftmann”:

You should know that we as developers find it frustrating to be told
of a problem, but then prevented from looking into it. We’d like to
investigate the problem you’re having, as it might be a bug, but we
can’t do that without the module.

If you don’t have any web space of your own in which to upload it,
try something like Mediafire.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Didn’t mean to dangle the carrot and yank it away from you(lol)! Here’s one for the books, I decided to remove a lot of components from the mod to reduce space(down to 1 simple holding chart and a few counters with the AoE trait) so I could send,but the size remains at 65 Mb! I loaded another version( of the same game system) and I’m not having the AoE problem. However, the other version is only about 5.5 Mb. The confusion over the size is that, except for the maps and perhaps the extra Globals(which were removed) it’s not much different. I don’t like to give up on things like this easily(since I’ve been waiting for a “VASSAL” for 30+ yrs) So as long as you are willing to work on this, as will I. Thanks much.

Yes, you should open up the module file with a program like 7-zip (the best I have found for doing this) and delete old images you are no longer using.

B.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

UGH! I can’t believe the amount of extra images were in there! Most were redundant. I have some re-working to do. I would put this issue on hold for the time being, if mine was the only one. I will get back to you when I have more news. Thanks for the help.

Bug [2811211] Area of Effect does not display in all Zoned Grids

Calculation of Area was not taking into account board offset in multi-board
setups.

Fix committed to swampwallaby-3.1@5762

B.

Thus spake “Brent Easton”:

Merged to 3.1@5769, trunk@5770.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)