Bad Data in Module: Expression evaluation error

Vassal 3.2.16
Java version 8 update 101
Aspire E1-771
OS Windows 10

Whilst in Module Editor mode I am getting a Bad data in module message every time I open a particular Calculated Property. When I run the module Everything works as I want it to without any Bad Data in Module messages.

This is the message I get:

  • Bad Data in Module: Expression evaluation error JF CW Build Start-Calculated Property[JFBSValNo]={(((MultValNo*JFRTValNo)+5)/10)}, Error= inline evaluation of: ``_xyzzy=_plugh();’’ internal Error: Unimplemented binary String operator

Anyone know what could be causing this or what I am doing wrong?

EDIT- Just checked and I am actually getting the message when I click on the Piece that contains the Calculated Property in order to edit its properties, not when I open the Calculated Property.

OK I still do not know what the message meant or why it was appearing, but I narrowed down the problem to the Label in the piece which I was using to display a Calculated Property.

I have managed to get rid of the message by using the Calculated Property to set a Global Property and then getting the label to display the Global Property.

So problem solved for me, but as I say the error message is very unclear and I still do not know what it means.

Could have been a simple matter of reloading the mod after editing it. Some times things don’t work right if you’re testing a mod during editing without closing and re-loading the mod. In my experience, I’ve found this to be true quite often when adding / manipulating Global Properties.