Bug in Dice System

3.2 svn8382

I think I found a new bug in the dice system.

I’m using a dice component to roll a value between 2001 and 4000. I have it set as…

Number of dice - 1
Number of sides per dice - 2000
Add to each die - 0
Add to overall total - 2000

All the results I get are less than 2000 which tells me that it’s generating a random number fine but it’s not including the additional 2000.

If I set the 2000 as “Add to each die”, it works fine so it seems to be a problem specifically with the “Add to overall total” option.

Did some more testing and this does appear to be a consistent bug. I haven’t gotten any die rolls to add the additional value.

Submitted as bug #4849

Did you click the ‘Report Total?’ checkbox? Unless you do this, the total is not reported, only the individual die rolls.

That fixed the problem. I assumed that “Report Total” would mean that a message would be displayed reporting the die roll and I didn’t want a message so I didn’t check it. Perhaps the that could be altered to make it clearer as it never occurred to me that “Report Total” meant add the values together to create a total.

I’ll remove my bugs from the bug list.

Sorry but I can’t figure out how to delete the bug reports.

Bug #4849
Bug #8723

Normally you can’t remove bug reports.
They get marked as being resolved in some way.
In this case, the report was resolved as “Invalid”, i.e., not a bug.

On Fri, Oct 5, 2012 at 6:13 AM, DrNostromo drnostromo@drnostromo.comwrote:

Sorry but I can’t figure out how to delete the bug reports.

Thus spake DrNostromo:

Sorry but I can’t figure out how to delete the bug reports.

Close them as invalid.

J.