Cannot load any module

This is my computer:

OS: Windows 10
CPU: Intel i7-4700HQ @ 2.40 GHz
Memory: 16 GB
Video: nVidia GeForce GTX 870M
Vassal Version: 3.2.16
Java Version: Java 8.0 update 111 (from … -installed, because showed an error).
Vassal Module Name and Version: Monopoly Deal 1.0 (but I tried other ones and I get the same problem)

This is the first time I try to run Vassal. I just found out about it and was very excited about it, but I have not been able to get it to run. Every time I open a module, the mouse pointer turns to a wheel and it never stops. Nothing happens. I have tried running as Administrator, I uninstalled my anti-virus, my firewall, and still nothing.

The error shown in the Error Log is:

2016-12-06 22:49:35,358 [0-main] INFO VASSAL.launch.StartUp - Starting
2016-12-06 22:49:35,360 [0-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2016-12-06 22:49:35,360 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_92
2016-12-06 22:49:35,360 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.16
2016-12-06 22:49:35,443 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2016-12-06 22:54:12,266 [0-SwingWorker-pool-1065079925-thread-1] INFO VASSAL.launch.AbstractLaunchAction - Loading module file D:\Downloads\Monopoly_Deal_1.0.vmod
2016-12-06 22:54:13,387 [0-SwingWorker-pool-1065079925-thread-1] INFO - launching C:\Program Files\Java\jdk1.8.0_92\jre\bin\java -classpath lib\Vengine.jar -Xmx151M -Duser.home=C:\Users\Adrián -DVASSAL.port=54813 D:\Downloads\Monopoly_Deal_1.0.vmod C:\Users\Adrián\AppData\Roaming\VASSAL\tiles\f036fe4b1de43b4a1e4c23c0cf6063380c07b328 256 256
2016-12-06 22:54:13,918 [2-main] INFO - Starting
2016-12-06 22:54:14,018 [2-main] INFO - Tiling images/2M.jpg
2016-12-06 22:54:14,138 [2-main] ERROR - Software caused connection abort: socket write error
at Method) ~[na:1.8.0_92]
at ~[na:1.8.0_92]
at ~[na:1.8.0_92]
at ~[na:1.8.0_92]
at$4.receive( ~[Vengine.jar:na]
at$4.receive( ~[Vengine.jar:na]
at ~[Vengine.jar:na]
at ~[Vengine.jar:na]
at ~[Vengine.jar:na]
2016-12-06 22:54:14,139 [2-main] INFO - Exiting

Please help.

Thus spake Daazor:


  • Software caused
    connection abort: socket write error at Method) ~[na:1.8.0_92]

My guess is that Windows is blocking the tiler from opening a socket
on the loopback device (