Does Not Stack with 3.5.0 and 3.51

I have some Victory Point markers in a game with Does Not Stack trait. I was using Alt-Click to select them. That way either Click or Shift-Click wouldn’t select them letting them be accidentally moved when moving counters stack above them. I need to select them to be able to flip them.

With Alt-Click now doing the “Flare” they can’t be selected and I don’t want to use just a Click or Shift-Click to select them so they don’t get accidentally moved. I thought I heard that the Does Not Stack trait was going to add Alt-Shift-Click as a method of selecting. Is that going to happen?

I can’t comment on the new Flare function, but regarding your goal in bold–one alternative to this is to employ the Game Piece Layers feature of a map. This will separate classes of pieces so that different classes aren’t allowed to stack with each other and you can control their drawing order relative to each other. So in this case, you might choose to put your VP markers in a layer that always draws below unit counters. Maybe you already know about this feature and there are other reasons for not wanting to use it, but just FYI. I’ve always found the magic key combo to allow select/move on the Does Not Stack trait to be very user-unfriendly, because you have to document it somewhere and then rely on users to read it (users reading documentation is hopeful at best).

I’ve discussed this with Joel on a VASL forum. I have the same issue in that I can no longer select pieces with the Does Not Stack trait with Alt+click. All I get is the flare. The underlying piece is not selected.

VASSAL 3.5.1 added an Alt+Shift+click option to the band select options but again, I can’t use it because as soon as press Alt, I get the flare. The band is not drawn nor are the pieces within the band selected.

So as far as I know, the only effective way to select or band select a Does Not Stack piece is Shift+click. I really don’t like this option because these pieces inevitably get selected unintentionally.

I do like the flare addition. I’m hoping there is some way to make the Does Not Stack select and band select options deconflict with the flare.

edit: I should add that there is a way to change the flare key combo to something other than the default alt+click. I’m not sure how to do it even though I’ve seen the instructions. It involves editing code. I was going to learn how to do this but decided that it’s better to keep the VASSAL default since users will quickly get accustomed to using it. Requiring users to learn a new key combo for specific modules probably isn’t the best way to proceed. Thus, IMHO, it’s better to offer more select and band select options for the Does Not Stack trait.

I just learned that there is a Map Flare configuration window under the Main Map Map Window. You access it when editing a module. This allows easy configuring of the map flare, to include more key combo options; no coding required. Thanks VASSAL Cabal! I’m still not sure that changing the flare from the default is best for the Users playing with many different modules but it does allow the alt+click selection options for the Does Not Stack trait. And I’ll bet I can think of a way to let Users know what the flare key combo is without making them read a help file. No one reads those :slight_smile:

If it proves too much for the VASSAL team to add Alt-Shift-Click to the Does Not Stack trait then I’ll probably switch the Flare to Ctrl-Click for the modules I create. Thanks for pointing out the different Flare options.

I did a little more testing and I’m having an issue still.

I changed the flare key combo to ctrl+shift+click and it works great.

However, I still cannot select Does Not Stack pieces with Alt+click. This worked prior to VASSAL 3.5.0.

Interestingly, I can band select Does Not Stack pieces but I first must hold click and start drawing the band and then press alt while completing the band. Maybe that’s normal computer interface but I don’t recall this being the case. What makes it interesting is that I’ve got my Does Not Stack trait set to select with alt+click and band select normally.

I’m using VASSAL 3.5.1 with Windows 10 64 bit.

Let me make sure I understand your problem case.
(1) You have a piece with a Does-not-Stack trait. Correct?
(2) “Select Piece” item in the Does-not-Stack is set to what? Alt key?
(3) “Band Select” item in the Does-not-Stack is set to what? Alt key?
(4) And there’s a flare component on the Map but you have it set to Alt+Shift?

And then your problems are…
(a) While holding the Alt key you click on this piece and it won’t select?
(b) While already dragging a box you can “add the Alt key” and then the piece selects?


Hi Brian,

I appreciate your time looking into this. Thanks. My answers in bold italics above. I could make a paired down version of the module for you if that would be helpful.


Oh gosh yes a pared-down minimal module that reproduces the problem would be SUPER helpful.


Attached are two two mini-modules.

Also a vsav file with a hex outline marker with a Does Not Stack trait using Alt-Click to select and two other counters.

The 3-2-17 DNS Module.vmod was made using ver 3.2.17 and you can select the hex outline marker using Alt-click

The 3.5.2 DNS Module.vmod was made using ver 3.5.2 Snapshot… and you can’t select the hex outline marker using Alt-click

In the real game I don’t want to use just Click or Shift-Click to select the hex outline marker because it will often be stacked with other counters and don’t want it selected and then be accidentally moved.

Since the default for “Flare” is Alt-Click I’d rather not change that since players will be used to it.

I know this is easy for me to say and may be a bear to program but I’d like to see the Does Not Stack trait add other selection options such as Ctrl-Click.


Ah, thanks Jim – I think I’ve found the problem that was unduly screening Alt out of the selection mix. Should be fixed in 3.5.2 and there may be a test build here to try soon.

Note that in your test module Alt+Click is ALSO used for the Flare, so presently in the “fixed” version it will do both things (select the unit AND do a flare). But if you moved Flare to a different key combo then Alt will still work as the selection key.


Great! Look forward to checking it out with 3.5.2.


I was just going to get a test module ready but thought I’d check here first. Looks like you have what you need flesh out this issue. Thanks Jim and Brian. I look forward to trying out 3.5.2. Brian and Joel, thanks again for your excellent support of VASSAL. It is most appreciated!


Try 3.5.2-SNAPSHOT-16b60e0f1:

Does that fix the problem for you?

Unfortunately no. Still exhibiting the same behavior. Here’s a link to a test module that duplicates the issue I’m having:

All the environmental pieces have a prototype that includes the Does Not Stack trait. This trait is configured to select with Alt+click and band selected normally.

The flare key combo is ctrl+shift+click.

Once a piece is placed, I cannot select it again with alt+click.

I can band select a piece by click dragging a band around it and then holding down the alt key.

If I hold the alt key and then try click dragging a band, the band does not appear.

The map does use layers but the environmental pieces are not assigned to a layer. I’ve deleted out the pieces that did have an assigned layer as none of them possessed the Does Not Stack trait.

Hey Joel,

If you use the vmod and the vsav I uploaded in an above reply and open them with the latest snapshot you’ll see you still can’t select the hex outline with Alt-Click


Hi Al - I just ran your module using the test-build that Joel put up above (3.5.2-SNAPSHOT-16b60e0f1) and everything worked right – none of the problems you mention were happening any more.

  • I dragged some contrails onto the map
  • I was able to Alt+Click on them to select them
  • I was able to, while already holding Alt, drag a band select and successfully select them. (I could also add the Alt later)

Could you please verify you were running on the correct snapshot test build? (“sometimes accidents happen”). That seems like the most likely issue - otherwise it would be more likely to be some Mac-specific thing but I think you’re on Windows, right?

Hi Jim – I just ran the snapshot that Joel put up above, using your module & file, and I was able to select the green hex outline. I of course had to click outside of the stacked counters that were on top of it (or I ended up selecting them instead), but as long as I did that I had no problem Alt+Clicking the green outline thing and having it select (and then I could drag it around or whatever). I’m mystified how both you and Al are running that test build and not seeing improvement – normally I would suspect that someone was either accidentally running under their regular Vassal instead of the snapshot (close your other vassal windows just to be sure), or accidentally installed the wrong snapshot build (I manually installed the build myself just to sanity check), but with it seeming to be wrong for TWO people I’m really mystified. Could you give it another try “just in case”? Brian

Sorry, I wasn’t clear. It’s the green hex-outline marker that has the Does Not Stack trait, not the other counters. In games I use it for marking who controls a hex and it can be flipped. If you open it with 3.2.17 you can Alt-Click the hex-outline marker and then Ctrl-F to flip it.

But I was able to select the hex-outline marker in the snapshot build with Alt+Click? And then I flipped it with Ctrl+F and it turned blue.

That’s why I’m mystified.