Errant discard, Deck component

Hi all;
Just when I thought I had these cards dealing and discarding as expected I found something else. I have the decks set up to automatically return Discards and reshuffle when the Deck is depleted. All works fine until the first reshuffle …

…the card which is in position X “Command Station” will move to the left with the others as each card is dealt, however, when it is discarded, instead of going to the Discard Deck it appears in the upper left of the Discards tray…

…if you click & drag the errant Discard to its correct position, the dealing/move/discarding will continue as expected and will not do this again even after multiple reshuffles.

I have include a module that demonstrates this. Left click on the Deck and the cards will deal/move/discard automatically until the card marked X discards after it moves to the extreme left. It will happen to whatever card is in this position prior to reshuffle, in this Preset it will be “Command Station”

I don’t think it is something I have done because this does not happen again after you click and drag the errant card to the discard deck.

[EDIT] So far I have replaced the Return To Deck with a Send To Location and the same thing happens.

[Download Sample]

Thanks in advance;


Well this is perplexing. Today I disabled the Automatic Reshuffle and restocking of the deck. Now the Deck can be restored only with the Right-click menu. Still the same problem. Regardless if the Deck is empty or not when it is restocked that one Discard does not end up in the Discard Deck. Also , same as before, if the errant card is dragged back into the Deck with the Mouse, this does not happen again.

Next I will try replacing the Discard Deck with a Zone and if that doesn’t work then there must be something in my configuration which means bad luck the cards will have to be dealt click and drag. Spent far too much time on this one thing.


Hello again;
I replaced the discard Deck with a Zone as mentioned previously. The other changes were: Return To Deck replaced with Send To location, Discard Deck replaced with a Multi Zoned Grid and a Module Level Global Key Command which replaces the "send entire Deck to another Deck function in the Deck properties. The GKC now moves all Discards to the original Deck as part of the same automated process used previously. The fault has disappeared and the cards loop from Deal/Move/Discard/Return Discard/Shuffle without any cards going astray.

I am no expert but I believe the problem is with the Deck sub-component for the following reasons.

  1. When using the Deck sub-component for Discards, an entire Deck was cycled without error until after the Discard Deck returned the Discards.

  2. When the errant discard was placed manually in the correct position, the cycle continued indefinitely without fault.

  3. When the Discard Deck is replaced with a Zone, no fault occurs at all.

The sample module described in (3.) can be downloaded [here]

Thank you for your time.



Hi all;
Referring to my original setup (which does not work. Here is my configuration in the Deck properties for the Discard pile…

…the circled part is what I was using to return all Discards to the original Deck. The manual says this can be used specifically for this purpose…

… which it does except I have the situation described before where a discard will go astray. I also tried disabling this part of the Deck Properties and replacing it with a Deck Send Key Command which does the same thing however the problem repeats again. Remembering that using a Zone instead of a Deck works fine the issue must be either with the Deck itself or possibly the Send To Deck trait which is used to send a discard to the Discard Tray. Has anyone used a Deck in similar situations to mine and had a problem? I am trying to determine why this does not work because it should.

My final Test will be to replace the Send To deck with a Send To Location and see what happens.

Beginning to feel like I am talking to an empty room here.


Same problem replacing the RTD with a STL so whatever is going on it has to do with using a Deck to hold the Discards. I have a solution that works and will go with that leaving the experts to sort out what is wrong with the Deck component (if anything). too much time wasted on this.


I took a look at the posted module yesterday, but quickly concluded that I don’t know what is meant to be happening and don’t know the minimal case for reliably reproducing the problem. I saw the bug several times but don’t know if it was me triggering the right conditions or just by happenstance. The report that warns of the “Illegal action” printed quite a few times to the log, but I just didn’t have the time or energy to try and understand all the logic behind when it should and shouldn’t appear, let alone why it’s firing when it ought not.

Hello Joel;
Thanks for taking the time to look at this.

I can’t be sure that is a bug I only think it is based on my limited knowledge and the reasoning combined with some evidence I have outlined earlier in this thread

I thought the instruction I provided were clear enough my apologies if they were not I apologise.

I have gone through all the steps taken to attempt to isolate what I believe to be a problem with the Deck and am more than happy to assist someone in the know, identify this potential bug. I have spent considerable time on this and without some assistance it is all for nought. My apologies for the inconvenience I have caused you, I can most definitely promise you it will not happen again as I know my limitations.

[edit] hmmmmm. too many apologies I must be tired too LOL! Oh well.