Error (log included) using vassal 40k (link included)

Hello,

Firstly, let me say thank you for such a fine program. Aside from this little problem its been smooth and provided me with alot of fun. I just recently updated both the vassal engine (from 3.14 to 3.15) aswell as my module vassal40k from 5.1 to 5.2 http://www.mediafire.com/?mg1d0jdmq4u or http://www.vassal40k.com/downloads/step-two/

When i start up the module, i get the following error error log:

21 May 2009 00:26:58.908 0 – Starting
21 May 2009 00:26:58.909 0 – OS Mac OS X
21 May 2009 00:26:58.909 0 – Java version 1.5.0_16
21 May 2009 00:26:58.909 0 – VASSAL version 3.1.5
21 May 2009 00:26:59.860 0 – Manager
21 May 2009 00:28:05.627 0 – Loading module file /Users/jonboug/VASSAL/V40k_V5-2 www.vassal40k.com.vmod.zip
21 May 2009 00:28:05.674 0 – Loading module V40K 5.2 [www.vassal40k.com]
21 May 2009 00:28:05.676 0 /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java -Xms256M -Xmx512M -DVASSAL.id=1 -cp /Applications/VASSAL-3.1.5.app/Contents/Resources/Java/Vengine.jar -Xdock:name=V40K 5.2 [www.vassal40k.com] -Xdock:icon=/Applications/VASSAL-3.1.5.app/Contents/Resources/VASSAL.icns VASSAL.launch.Player
21 May 2009 00:28:09.761 1 VASSAL.build.IllegalBuildException: java.lang.UnsupportedClassVersionError: Bad version number in .class file
at VASSAL.build.Builder.create(Builder.java:121)
at VASSAL.build.Builder.build(Builder.java:73)
at VASSAL.build.AbstractBuildable.build(AbstractBuildable.java:68)
at VASSAL.launch.BasicModule.build(BasicModule.java:142)
at VASSAL.launch.BasicModule.build(BasicModule.java:105)
at VASSAL.build.GameModule.init(GameModule.java:783)
at VASSAL.launch.Player.launch(Player.java:79)
at VASSAL.launch.Launcher$1.run(Launcher.java:161)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at VASSAL.tools.DataArchive.findClass(DataArchive.java:370)
at VASSAL.tools.DataArchive.loadClass(DataArchive.java:346)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at VASSAL.build.Builder.create(Builder.java:101)
… 14 more

21 May 2009 00:28:09.945 1 – V40K 5.2 [www.vassal40k.com] version 5.2
21 May 2009 00:28:09.945 1

21 May 2009 00:46:33.762 1 – Exiting
21 May 2009 00:46:39.469 0 – Loading module file /Users/jonboug/VASSAL/V40k_V5-2 www.vassal40k.com.vmod.zip
21 May 2009 00:46:39.473 0 – Loading module V40K 5.2 [www.vassal40k.com]
21 May 2009 00:46:39.474 0 /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/bin/java -Xms256M -Xmx512M -DVASSAL.id=2 -cp /Applications/VASSAL-3.1.5.app/Contents/Resources/Java/Vengine.jar -Xdock:name=V40K 5.2 [www.vassal40k.com] -Xdock:icon=/Applications/VASSAL-3.1.5.app/Contents/Resources/VASSAL.icns VASSAL.launch.Player
21 May 2009 00:46:42.079 2 VASSAL.build.IllegalBuildException: java.lang.UnsupportedClassVersionError: Bad version number in .class file
at VASSAL.build.Builder.create(Builder.java:121)
at VASSAL.build.Builder.build(Builder.java:73)
at VASSAL.build.AbstractBuildable.build(AbstractBuildable.java:68)
at VASSAL.launch.BasicModule.build(BasicModule.java:142)
at VASSAL.launch.BasicModule.build(BasicModule.java:105)
at VASSAL.build.GameModule.init(GameModule.java:783)
at VASSAL.launch.Player.launch(Player.java:79)
at VASSAL.launch.Launcher$1.run(Launcher.java:161)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at VASSAL.tools.DataArchive.findClass(DataArchive.java:370)
at VASSAL.tools.DataArchive.loadClass(DataArchive.java:346)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at VASSAL.build.Builder.create(Builder.java:101)
… 14 more

21 May 2009 00:46:42.199 2 – V40K 5.2 [www.vassal40k.com] version 5.2
21 May 2009 00:46:42.199 2

i can still access the module and go online, but i find that some features, including a row of command buttons are missing for me. Its odd, and i was hoping youd know the solution. Thank you for your time.

The solution is to have the module author recompile their custom classes
they have added to the module in Java 5.0 not 6.0

Post generated using Mail2Forum (mail2forum.com)

Hi,

Whoever has created the 5.2 version of the module has included custom Java code that has been compiled using version 1.6 of Java. As you only have version 1.5 of Java installed, this is causing the error.

Please contact the module author and ask them to recompile their custom code using Java 1.5 and release a new version of the module. This is the preferred solution and any number of Vassal users may still have only Java 1.5 installed.

In the short term, if Java 1.6 is available for your version of MacOs, you could upgrade to it.

B.

*********** REPLY SEPARATOR ***********

On 20/05/2009 at 5:50 PM ETP wrote:


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)