Fresh download not working?

Just tried to download Vassal after having uninstalled it previously, and it’s now giving me the following error message when I try to run the executable!

"The registry refers to a nonexistent Java Runtime installation or the runtime is corrupted.

The system cannot find the path specified."

I’m on Windows 7 Home Premium, and I just checked my Java on and it says I have Version 8 Update 101. I’m not sure what could be causing this. Help?

I’ve got the same problem.

I fixed it by installing Java 8 Update 102.

Where did you find that? Again, still says 101 is the most recent.

WARNING: If you are nervous about the registry, or not sure how to backup the keys before making changes, don’t follow this advice.

Update 101 introduced a fun problem for me where older versions took precedence (I believe because they are sorted like strings and not numbers, but that’s just a guess). Mine was something like update 89, which was no longer installed, but hanging out in the registry anyway. Have a look in your registry and delete any subkeys for older JVMs under HKLM\Software[Wow6432Node]\JavaSoft\Java Runtime Environment. You should see a 1.8.0_101 key under there, but if you see a 1.8.0_9x or 1.8.0_8x, delete or rename it. Look both inside and outside the Wow6432Node key if you have it (if not, you are on 32-bit Windows, and can just ignore that part).

The error I got mentioned Java Runtime Environment, not Java Runtime installation. A simple google search for those three words in the error message, Java Runtime Environment, led me to (Specifically this page) where 8u102 was freely available.

See the recent 3-page thread entitled Java update won’t let VASSAL launch, downforum.
People used various methods to resolve the problem, but for me it was resolved simply by deleting Java from my computer and downloading and installing the latest version manually from their website.