GKC seems to lack game piece properties

I have a module with a GKC that worked before, but after installing Vassal 3.4.3 the command does not do anything. It uses a Beanshell comparison to locate all Climb markers on the map, in order to remove them: {PieceName == “Climb”}.
I wanted to see if the expression was wrong, so I tried the expression builder, and I found that there were Global properties, and Vassall properties, but no Game Piece properties. Can they no longer be used in Global Key Commands?

Hi, Can you post a link to your module please?

Hi, Brent, thanks for your offer of looking at my module. It certainly helped me locating the problem because when I tried to reproduce the bug, I discovered that some Climb markers were removed as they should, whereas others did not, and I found that the markers that were not removed were the ones that were created with a “Place marker” command. The counter with the “Place marker” came from a scenario saved game.

My problem was caused by a scenario that was created with an earlier version of the module. I did use the update tool for saved games, but apparently this issue was not caught. I guess I have to recreate all five scenarios from scratch.

There are several recently fixed bugs in the 3.4.x series that specifically had to do with Game Refresh issues and older save versions that had Place Marker traits specified in prototypes. These traits where basically being quietly ignored by the refresh process.

At this stage, it would be safest to re-create your scenario startups, but hopefully, the Game Refresher will properly update such issues in the future.


I see I forgot to report back on this issue: it is resolved. The problem was with counters created by an older version of the module.