Help with the basics

I’ve designed a simple module ‘Jackson in the Valley’ but now want to add a revised version. Or better still replace the existing version. Convinced it should be dead easy but can’t for the life of me figure out how to. Can someone please help.

Apologies for being an idiot.

We all are idiots. Does anybody here know the answer to following: what is the purpose of life? From where we come from? And where do we go? Does it all make any sense? :smiling_imp:

It would help if you ask specific questions: what you try to achieve, what you struggle with?

To make a new version from scratch use File → New Module from VASSAL menu and design!

Thanks Grouchysmurf.

I considered just starting again but that seemed like a cop out. it must be possible to edit module pages because other people do.

So, here’s the specifics.

I set up module page ‘Jackson in the Valley’ using the command you refer to. A pretty basic attempt you will observe. While that was being moderated I made more changes to the vmod file so now want to:

  1. Add a new version to module page.
  2. replace the existing module file on the module page.

I’ve tried using the ‘Edit’ tab on the top right of the window and the ‘Edit’ option by the Files in the page code. I’ve tried using the ‘Upload Files’ command on the left. This weirdly doesn’t recognise the module file on my laptop as a vmod. All to no effect.

I’ve tried searching for help on google and the forum but all searches lead to the Module Editor not the Module Page Editor.

I think that maybe the answer lies in the Templates,but have no idea how to proceed.

This must be a simple thing so I was hoping someone like your good self could explain or point me to the appropriate manual / guide or tutorial.

if you cant edit the module page then this means you are not logged in to the wiki. Being logged into the forums is not the same as being logged into the wiki - they are separate log ins

Tim,

Thanks for the reply.

Regarding your 2nd note: Win 10 64bit, 4GB RAM, Vassal 3.3.2, Java v8 Update 261 1.8.0_261-b12, Module Jackson in the Valley.

Regarding your 1st note. I think I understand this point, more by accident than design. However, I load Vassal, search and load the Module page. Then I use the Log In option in the top right. This done the Edit option appears by all the headings and as an additional tab. I’ve also made sure I’m using the exact Log in details. Not sure if my Username is ‘Rnason’ or ‘rnason’ or both.

A further complexity is that the module file from the Module Editor appears as just ‘Jackson in the Valley’ with no extension in Windows explorer. Doesn’t seem to affect its functionality other than it won’t Upload. I resaved it as ‘Jackson_in_the_valley2.vmod’ using Save as and now have a version recognised by Explorer as a Vassal Module file. This worked fine in the ‘Upload File’ tool. Sadly, it appears to be uploaded to a general holding area not my Module Page. Even now I am still at a loss to understand how to add this file to the Module Page.So, after a promisiing few steps I’m none the wiser and remain in desperate need of help.

Thanks

Your module is now approved. You can now go to the module page and edit it by adding the file.
In edit mode, just copy the section where your other file is “linked” and change its name - basically you want to copy these 2 lines

{{ModuleVersion|version=1.1}}
{{ModuleFile|filename=Jackson in the Valley.vmod|description=|date=30-08-2020|size=|compatibility=3.3.1}}

paste it below the original lines and edit as required - i.e version number and filename, maybe date etc…

Then hit save. Changes then goes to moderation/ holding and usually gets approved within 24 hrs

Tim,

Thanks so much for the reply. I think I’m getting the hang of this. I do hpe I’m not burdening you for want of reading a readily accessed manual.

Anyway, I followed your advice and the table expands just so. Excellent. But, in the ‘Show Preview’ the new file appears as ‘Does Not Exist’. Am I right in now thinnking this is an artifact of the moderation process? I’ve editted the new file name exactly as it appears in the Uploaded files area. I’m hoping that once the edit is approved the file will exist. If I’m right all I need is patience. Is this correct.

Rob

No - it means you didnt set the file name properly. Everything is case sensitive (and space sensitive). Also I do not see your edit. You have to save it for it to go to moderation, otherwise all you are doing is editing and then discarding the change.

Ill edit your spece and you can fill in the info on the page - it should be obvious what to fill when you see it

Tim,

Thanks for the help. I think I see now that once I get it right in the Preview it turns BLUE. Errors come up RED.

Looks like once saved you only see the uneditted version. Waiting for Moderation I suppose.

Sorry that I’ve saved about a dozern edits. I’m confident the last one is good.

Anyway, thanks again for your patience.

Rob.

PS should I have been able to read all this in a guide somewhere???