I Upgraded to Windows 10 and now I can't move counters.

I upgraded to Windows 10, Reloaded Vassal, loaded Java. Everything works but I cannot move the counters. I can click on a counter but cannot move them around.

Please Help!


Can you clarify which version of Java was installed? Does this problem afflict all your modules equally?

Using Java 8, Update 231. I initially loaded it using Firefox, uninstalled it, loaded it with Windows Explorer. Still doesn’t work.

Is this a saved game file that doesn’t let you move pieces?

I uninstalled Java and Vassal. Reinstalled Java by Internet Explorer, then reinstalled Vassal. Still doesn’t work. It works just fine on another computer.

What module are you running and are you opening a saved game or starting a game from scratch?

Running Raid on Iran. Opening a saved game, playing by email. Everything works fine on another computer but doesn’t work on mine since I upgraded to Windows 10. And on my computer everything works but I just can’t move the counters.

If you use the wrong password or you never set up the correct password on this new system, then locked pieces could happen with some modules. Those modules would have assigned “restricted access” to pieces, which would nullify movement for non-owners. If the password is wrong, then it won’t see you as owner. This might be the problem. That’s why knowing if it’s a saved game is important.