Java update won't let VASSAL launch

This morning I updated to the latest Java version. Now when I attempt to launch VASSAL I get an error message that says - The registry refers to a nonexistent Java Runtime Environment installation or the runtime is corrupted. The system cannot find the file specified.

Yesterday VASSAL launched correctly. The Java update is the only difference.

I am running Windows 10. Any ideas for help?

I just downloaded and installed the VASSAL engine again. Same error message.

Same problem here.

No other update available for Java Runtime Environment.
A reinstall of Vassal does not resolve the problem.

Same problem: updated java and now trying to start vassal prompts a error message. :frowning:
windows 7

newguy Darren

Any news on how to fix the java update problem?

btw my name is Darren. I am new to this…

We need more information in order to help you. What version of Java is it that you’ve installed?

Windows 10
Java 1.8.0_101 = Java 8 Update 101. No obsolete version present.

Same for me yesterday also one Java update.

Java 8, 101th update

Worck before with WIndows 8 no problem.

I use Vassal 3.2.16

I had the same problem.
the solution for me was rebooting computer after installing new Java version 8.

note: it took 2reboots for some reason…

Same here, right after Java 8u101 update. Vassal 3.2.16 on Windows 10.

New Java installation causing problem: Version 8 Update 101 (build 1.8.0_101-b13).

I’ve been running Windows 10 for many months and the previous version of Java with no problems including yesterday. This morning I installed the new Java update per Oracle’s prompt. When I attempted to launch VASSAL is when I got the error message.

Problem solved!

Windows 10. Java Runtime Environment 8 Update 101.1

I noticed that my JRE was not 64 bits and that the Update 102 was available (manual download only).

I’m unable though to check in Firefox the Java plug-in.

I updated Java 8 on Mac OS X 10.11.6 to Update 110 build 13 and no problem with VASSAL 3.2.16.

OK, I solved the problem by uninstalling an old Java lying around, and also removing its key in the Registry.

I’m still having the problem

Windows 7 - Home Premium

Java 8 Update 101


Check whether you still have an older version of java installed. If so, remove it. If not, check whether an older version of Java left stale keys in the registry. If so, remove those. The problem is one of those two things.

Check whether you still have an old version of Java installed. The Java installer on Windows is horrible about leaving old major versions installed, which can prevent the newer major version from working. Remove any old versions you find.

Hi Joel,

I started having other problems and ended up getting a new PC. The old one had several years on it.


Same here.
Running Win7 Home Premium, 32-bit.
Java Version 8 Update 101.
No old versions of Java.

If you’re still having a problem after verifying that you have no older versions of Java installed, then you need to check the registry for stale keys leftover from the previous version of Java, and remove those.