LOS tool malfunction

Wherever I use the LOS tool, upon releasing the left or right mouse button, the end point shoots a LOS line off map.

An example of this: Start in hex A and end in hex B. Once I release the mouse button Hex B draws a line off the map from that point.

I tried this with other mods and the same thing happened. I am using the most current Vassal build.

Anyone else with this problem? Can anyone help with this?

Thanks!

The LOS tool has a bug, the bug report has been open for a long time and has the fix attached. If you play at 100% zoom, it won’t happen.

Thanks for the info. Do you know if this is being fixed? Is the 100% zoom the fix?

Thanks!

Forgot to add this:

Model: Dell Optiplex 755
OS: 7 x64
CPU: Intel Core 2 Duo 3.0 0GHz
Memory: 8GB
Video: Integrated (crap, but it works for now)
VASSAL: 3.2.16
Java: current
Module: All of them

Sorry, no idea… I’m not part of the dev team. There is an easy fix for all zoom levels, it just needs someone to apply it before they release the next version. I ended up just fixing it (and a few other annoying behaviours) locally and gave the Vengine.jar to anyone who wanted it. I’m also planning to add the fixed LOS tool to the Warmahordes module, so it will work for anyone even if they run an old version of Vassal.

Using 100% zoom is just a workaround.

I appreciate the info you gave me. Many thanks!

Hi Guys,
I’m just putting together a few outstanding fixes for the next version, I will include this one.
Regards,
Brent.

Great news, thanks Brent :slight_smile:

Thus spake Brent Easton:

Hi Guys,
I’m just putting together a few outstanding fixes for the next version,
I will include this one.
Regards,
Brent.

Let me know when you’re ready; I have one fix queued up for 3.2.17 as
well.


J.

I have just been trying to reproduce this problem without success. What LOS options are you using? Can you point me to a module that has this problem?
Thx.

No snapping, always persist, always visible, draw range, 3 pixels per unit (I don’t think these last two are important, but just for completeness). Set the zoom level to 150%, draw a line and then lock it - one end of the thread will jump to a crazy new position.

The Warmachine and Hordes module is the one I use the most.

I was using the SCS Day of Days module but it does the same Crazy Ivan with the Gulf Strike mod, or any other mod I try.

I appreciate you all for helping with this annoying issue. :slight_smile:

I tried this on the Band of Brothers mod and so far the Crazy Ivan does not manifest itself. Huh? That game is current for 3.2.16.

The Gulf Strike I have is 3.2.13 and SCS is at 3.2.16.

Very confused here.

If you hold ctrl while you draw the LOS in Band of Brothers, does it go nuts? I believe it’s related to persistence, because the bug was assigning the wrong values to lastAnchor and lastArrow. Don’t forget to change to non-100% zoom…