lost module file

Can anyone tell me what happens to a module file that accidentally gets dragged onto a desktop shortcut to the Vassal program? I had about 12 hours of work on updating a module, when I accidentally did this, now I can’t find the module file anywhere on a computer.

Yeah, I know, this is more of a general computer question than a Vassal question, but I can’t seem to google an answer.

I think it is just passes it as an argument to Vassal. I doubt it would have deleted your file.

As an experiment, I created a new mod file and repeated the action - the new one disappeared also.

Doesn’t this depend on what operating system you’re using?

Sorry, should have thought to mention. I’m using Windows XP.

That’s weird, it behaves differently for me with Vista. Have you tried doing a search for the file name?

XP huh? Well, I try not to use MS-anything if I can avoid it, but did you try dragging the VASSAL shortcut onto somewhere else on the desktop, just in case your module file is “underneath” it? (That probably makes no sense, but that’s what I would try if an icon just up and disappeared on me. That, and looking in the actual Desktop folder, assuming there is one.)

Yeah that’s a good point, maybe try the “Auto Arrange” option.

Yep, tried auto-arrange, and a search with no luck. With no luck on a simple search, I tried searching for every file created in the last week, and even searching for hidden files. And it’s not in my “recycle bin” either.

what about temp.zip / temp.mod files in your vassal directory? The last one will probably be close to your last working copy at least so you dont lose everything or too much

Kevan messages@forums.vassalengine.org wrote:

Post generated using Mail2Forum (mail2forum.com)

Unfortunately, no temp file. I was doing some experiments with another module at the same time, and it was the one that got backed up into the temp file.

Just bad luck all around, it seems.

Thus spake “Kevan”:

I’m scratching my head over how this could happen. Is it a VASSAL bug?
A Windows bug? Does the same thing happen if you drag a random file onto
any desktop shortcut?


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)