MacOS Big Sur

  • This isn’t a request for help, but is for any other Mac user who is having issues with running Vassal on a new M1-based Mac with MacOS Big Sur. No search identified a forum entry with this info, and reading through every thread since 10/2020 gave no solution.*

I just updated to a new M1 based Mac mini running Big Sur and received a “You don’t have Permission to run this application” dialog box on trying to run 3.4.13.

Using the “Notes for Mac Users” page (vassalengine.org/wiki/Notes_for_Mac_Users) set the “Open using Rosetta” check box on the Get Info page for Terminal, and then open Terminal. This asks if you want to install Rosettta, confirm you do. Once installed launch Vassal as normal, which should now open correctly. At least it worked for me… (And you can reset the Terminal check box when Vassal is working.)

Myk

Am I the only one who finds this somewhat hilarious–emulating an x86 processor to run a program written in a language specifically designed to be processor and OS-agnostic?

I stopped laughing at Java’s shortcomings many, many years ago :frowning:

In all seriousness, I suppose there should be a new package for M1 Macs that includes a JDK compiled specifically for them.

AdoptOpenJDK hasn’t provided a build for the arm64 architecture yet. When they do, I’ll add a build for it.

I have issues with Vassal performance on my new Mac Mini M1 with Big Sur… All maps freeze when zooming or moving. Also game pieces respond very slowly to mouse click.

Do you have same issues?

I have using Roads to Gettysburg II module.

Yes, it’s disappointingly a good bit slow on scrolling, especially on big modules. I’m hoping that the build for arm64 mentioned by uckelman will remove the need for Rosetta and improve performance.

I just setup my M1 Mac Mini and the first game I did a log for Imperial Struggle, module 2.0, engine version 3.5.3. I saved a log after a Peace Turn setup. When I reload the log, one of the Investment Tiles is gone, simply vanished.

I dont recall seeing this happen at all with the same versions on my old architecture Mac - may be able to check that later today.

Also seeing slowness overall.

I see that there are Azul Zulu Builds of the Java JDK/JREs for m1 - any thoughts on installing those?

I checked the issue with Imperial Struggle from an old architecture mac and the tile is still missing, so unless it happened when an M1 mac saved a log file its not due to the M1 chip

Is the problem reproducible? If so, what are the steps to do it?

You could try replacing the bundled Java with that one, or you could try running the “other” ZIP archive we provide with that JVM.

I spent some time today trying to recreate it - no joy. I do recall it happening at least once before - what is odd is I would have noticed the tile missing before closing my log, or my opponent would have noticed it on their go - it was only after I got back their file that it was missing - and they didnt touch the tiles in their log.

I’ll look around for the “other” ZIP files - in download page/area?

Yes, but here is the direct link: github.com/vassalengine/vassal/ … -other.zip

gotit - thanks! Not sure when I’ll get to testing it but will report back if I do

I have tried Azul Zulu Builds of the Java JRE for m1, great performance improvement, thanks!

We’ve started making test builds for M1 Macs. You can find them in the normal place for our test builds: vassalengine.org/builds/

The M1 Mac builds will have “macos-aarch64” in their name. E.g., you could try this one: vassalengine.org/builds/build/78570087

If you have an M1 Mac, please try a macos-aarch64 test build and let us know how it works for you.

I just downloaded the build/78570087 - unzipped and dragged the DMG to the apps as always - replacing existing, then went to settings and permitted it to be launched - went to launch pad and selected it - but it doesn’t launch - this is on an M1 Mac Mini - anything I am missing?

Is there anything in the errorLog after you try this? Is there any output of any kind?

If you open a terminal and go to Contents/MacOS/jre/bin under where the DMG has been installed, you should see the java executable. If you run that with “./java --version” what output is there?

Im a bit rusty on running console and terminal - but I did try to launch with console open and I see this in the system.log:

Jul 29 09:47:36 williams-Mac-mini com.apple.xpc.launchd[1]: Coalition Cache Hit: app<application.org.vassalengine.VASSAL.10294896.10295052(501)> [3319]
Jul 29 09:47:36 williams-Mac-mini com.apple.xpc.launchd[1] (application.org.vassalengine.VASSAL.10294896.10295052[9323]): Service exited with abnormal code: 1

I cant figure out where the Contents/MacOS/jre/bin is - I put the original DMG in a subfolder under downloads, and the install process usually makes a file in “Applications” but in Terminal I dont see Contents/MacOS/jre/bin and so on (sorry for being a bit dense)

Also - looking in Library/Java I see dirs for Extensions and JavaVirtualMachines but both appear to be empty - may be an issue seeing “hidden files” with ls command? Again quite rusty

I think the full path for the java executable should be /Applications/VASSAL.app/Contents/MacOS/jre/bin/java, but I’m not a Mac user so I’m not confident of that.

Would someone who is a Mac user offer some advice here please?