Map problems with imported adc2 modules on mac

Hi all,

Maps from imported adc2 modules take about 30 minutes to draw no matter what the size of the scenario and trying to rescale them causes the map to vanish and never return. I have not encountered this problem with other vassal modules.

Im using a 1GHz 12" powerbook G4 with 1.25 GB ram. The graphics card on this laptop has 32MB of video ram and Im using an external monitor with laptop cover closed and running with resolution 2048x1152. Im using mac os 10.4.11 with the latest java update installed. Ive allocated 768MB to Vassal with a minimum of 512MB.

Thanks.

Which ADC2 module?

  • Michael.

2009/3/4 p-brane <messages@forums.vassalengine.org (messages@forums.vassalengine.org)>

Post generated using Mail2Forum (mail2forum.com)

Thus spake “p-brane”:

In order to troubleshoot this, we need to see the converted module(s).


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

I`ve tried four: Barbarossa AGN and AGC, Barbarossa to Berlin, and A World at War.

Where do I send them?

Thus spake “p-brane”:

Is there someplace you can put them so we (in this case, probably Michael)
can download them?


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

I’m downloading A World at War now. I’ll let you know what the result is.

  • M.

2009/3/5 Joel Uckelman <uckelman@nomic.net (uckelman@nomic.net)>

Post generated using Mail2Forum (mail2forum.com)

I downloaded, A World at War, imported the “Global Historical Campaign Setup.OPS” into VASSAL, ran it, and it appears to work flawlessly. It’s a big module, but the map appeared in under 5 seconds which is actually pretty good given its size. The zoom feature works well and there’s minimal delay.

That being said, 512 MB for the maximum heap was not enough and it immediately complained about that. I raised it to 1024 MB and it was fine. The alternative to this, you can turn on “Prefer memory-mapped images for large files”, which I also tried. On start up, the initial draw to approximately 30 seconds – quite a bit slower. But once it was displayed, there were no problems. I also tried zooming out in this mode and the performance was still pretty good.

There’s does not appear to be anything wrong with the importer. You may be experiencing some memory issues given the size of the map. Java keeps it’s own private memory storage mechanism which you have to set manually in the preferences.

However, 30 minutes seems like a serious problem. It may be that you’ve set the maximum heap space too high and your computer is swapping out to the hard drive. If you’re seeing a lot of hard-drive activity, decrease the maximum heap space and turn on “Prefer memory-mapped images for large files” instead – it would be much more efficient. It actually appears to work quite well with that setting.

I haven’t tried the other modules, but this one appears to be fine. I also haven’t tried other OPS files in A World at War but the one I chose sounded big. Let me know if there’s a specific OPS file that’s causing you problems in particular.

Just to make sure, are you running the latest version of VASSAL (3.1)? Are there any other details you could share with us that might help us to sort out the problem? What kind of memory do you have on the computer? What is the operating system?

  • M.

2009/3/5 Michael Kiefte <mkiefte@dal.ca (mkiefte@dal.ca)>

Post generated using Mail2Forum (mail2forum.com)