Mark Moved Bug Report

In the VASL module users have access to a Mark Moved preference under the general tab in Preferences.

This preference seems to have disappeared between 3.6.11 and 3.6.12.

The mark moved functionality continues to work . . . which is the problem. There is no longer the capacity to turn it off which some players like to do.

I have tested this with various combinations of VASL and VASSL from VASL6.6.2 to VASL6.6.6 and from VASSAL3.6.7 to VASSAL.3.6.14. In those tests, moving from 3.6.11 to 3.6.12 is what caused the difference.

The change is very likely this one:

Try the build with this PR. Does that solve the problem for you?

I’ve merged the PR. These changes will be in 3.7.0-beta3.

Sorry I did not get to the PR. Got backed up with other stuff. I will grab the beta3 and test it. Thanks.

Am I right in thinking that 3.7.0-beta3 is not yet out?

Yes, you are right, not out yet.

Released just now: Vassal 3.7.0-beta3 Released


I am having an issue getting the Show Marked Moved preference to work.

I have downloaded 3.7.0-beta3. I have edited my VASL module and saved it using 3.7.0-beta3. When in Editor mode, I check Main Map properties and for “Mark Pieces that Move” I select Use Preferences Setting.

When I run VASL and go to preferences, the preference shows up in the General Tab. I deselect it. I restart VASSAL and VASL. I open a game and move a unit; it shows the Moved tab.

I check my VASSAL preferences file in AppData. . . . It shows markMoved = true; showMarkMoved = false.

Any thoughts?

Hi Doug,

I booted up one of my modules to check, and I had no problems using the exact same settings (the map set to “Use Preferences Setting” and then flipping on and off the “Show when pieces have been marked as moved (if module supports)” preference – with the preference on I see the “moved” tabs, when I turn the preference off the moved tabs disappear.

Can you send me the specific copy of the module you were working with so that I can see if I can reproduce it?



Hi Brian

Thanks very much. How best to send it to you? VASSAL doesn’t seem to want me to share it here. Tried to paste a dropbox link to it but was not permitted.

It is a VASL6.6.7-beta1.vmod saved with 3.7.0-beta3. About 20mb.


Maybe paste a dropbox link altered “just enough” to not look like a link to the irritating computer?

(Or send it to me link on discord)

Oh I see – you guys aren’t actually using our MovementMarkable trait, you have your own custom code trait ( you use instead.

You’d just need to update your trait to check the preference in its “draw” and “boundingBox” methods. Shouldn’t be hard, see the code snappy below. (Obviously you will need to be compiling VASL with 3.7 code for that to be visible for you)

Eyeballing it I’m not actually sure why you guys have a forked Mark Moved trait because yours doesn’t seem to do anything “special” it’s just old? Though I imagine swapping back takes a bit of care and diligence that may not be what anybody wants to actually do.



Thanks Brian but no joy in Mudville.

I made the changes, including compiling the 3.7.0-beta3. When I run it in my IDE, I get the following:

java: cannot find symbol
symbol: method isShowMarkMoved()
location: class

When I build VASL using Maven, it builds fine, using 3.7.0-beta3. I then run it using 3.7.0-beta3. It loads and opens a game. I move a unit, no MarkMoved tab, regardless of preference setting.

So, I still don’t have it set quite right. I don’t know what is causing the “cannot find symbol” error message. The class clearly imports The IDE has no problem recognizing the method call to isShowMarkMoved() until build time and then it goes AWOL.


I see this in the pom.xml:


If you haven’t updated the version locally, Maven will be building against 3.6.19, not 3.7.0-beta3.

I have absolutely updated the pom locally and am sure that Maven is using 3.7.0-beta3. Thanks.

It’s good to have confirmation that the pom.xml is correct. It sounds like your IDE is pointing to the wrong Vengine.jar, but beyond that I can’t offer any further advice.

Thanks Joel and Brian for your help on this.

I came back to this bug because I was using the latest 3.7.0 build to test a fix (from Joel) for a chat window issue. Using your suggestions, I have the MarkMoved preference working properly in VASL.

Took a while but I got there.

Thanks again.


1 Like