Mask image disappears if Piece rotates

The mask image is only visible if the Piece is in the true north (initial facing). If I rotate the piece, the other piece images rotate properly but the mask image disappears. The mask image only reappears if the piece is rotated back to it’s initial facing. I’m Running Windows 10 Vassal 3.4.8 on HDCP (laptop) and non-HDCP (desktop) displays. It happens on both.

PS The mask image works for the opposing player, but not for the owning player.

Has any developer had a chance to look at this or at least log the error? I’ve confirmed that the issue dates back to at least 3.2.17.

Would you able able to post a minimal test module showing the problem?

Maybe I’m missing something, but the placement of the “Rotate” property in the stack of properties for a piece makes a difference, at least for me. I have pieces with many different attributes, and by placing the rotate property at the BOTTOM of the property list guarantees that all information above it rotates properly. Maybe check the order of this property in that side’s pieces, and ensure they match how the other side’s pieces are built - just to verify that it isn’t a bug?

Joel, I’m PM’d you a test module.

I don’t think it’s the location of my Rotate trait. It’s below the Mask trait and everything else above Can Rotate works.


Have you had a chance to look into this issue yet? My holiday break begins in 5 days and I was planning to continue working on this module. But I’m at an impasse until I know whether this is a bug and if so, whether it’s fixable in a future release. Thanks.


I’m looking at the test module now.

Looking specifically at the “American Medium” prototype: You have the Mask trait under the “Vehicle” prototype, and it’s the Vehicle prototype which contains the Can Rotate trait. I’m not sure why that doesn’t render the mask image rotated.

To clarify, within the “American Medium” prototype, the Mask trait is above the “Vehicle” prototype. which contains the Can Rotate trait. This seems like a bug correct?

I always speak of the traits as a stack, so “below” is nearer to the bottom of the stack, i.e., closer to the Basic Piece trait. The editor shows the trait stack growing downward, which is unfortunate.

Got it. Anyway, I created a stripped-down Piece sans all the other traits as I was thinking maybe it’s an interaction with another image or trait that causes the mask rotation to not work. No such luck. Same behavior with a Piece that simply consists of:

Basic Piece
Can Rotate - Facing

If I arrange the traits as:

Basic Piece
Can Rotate - Facing

The mask always works, but of course, no longer rotates.

I think I’ve found what’s wrong—the VISIBLE_STATE property of the Can Rotate trait isn’t having the SELECTED property included in it in all cases. I’m not sure why not yet.

Try VASSAL-3.4.12-SNAPSHOT-bug13850-d6caf3b17:

Does that solve the problem for you?

That fixed it. Well done!

Thus spake m3tan:

That fixed it. Well done!

This fix will be in 3.4.12 in a day or two.