Maximum Heap Size Too Large

Ever since I upgraded to 3.1.3, I get this error message when I open a module: “Maximum Heap Size Too Large”. I check preferences and see initial heap/maximum heap to be 256/512. I halve both and the message goes away. However, even when I try to create a brand new module from scratch, I still get the message. (The new module was also 256/512). Is there somewhere I can set configuration to avoid the message with new modules? Any advice on how I should set these parameters?

Thus spake “shilinski”:

How much RAM do you have?


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

I find this engine yesterday, so I give a try today.
I downloaded the v3.1.4, but I have the same problem of shilinski.

When I open a new module, the “Maximum Heap Size Too Large” pop-up appears. After I look up on the preferences the sizes (even if I do nothing), the module loads. If I don’t do that step, the game doesn’t make his supposed load.

Is kind of annoying when I load a module, this Heap message appear.

And my RAM is 512 Mb.

Thanks,

Thus spake “FRCA”:

The point of the message is to be annoying—it’s telling you that you have
a setting which is not appropriate for your machine.

The default maximum heap size is 512MB, which is too large if you only have
512MB RAM. You will keep seeing this warning until you set the maximum heap
to less than the amount of RAM you have. With 512MB of RAM, I would set the
maximum heap to no larger than about 300MB or so (and also turn on “Prefer
memory-mapped images” in the Preferences).


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Well, after trying some new experiments, I figured out the problem.

The problem is on the module itself, that means I have to change the memory heap after I open the module.
And every module I have to load, if I didn’t edit his preferences before, he will keep going to pop-up the Heap message.

Anyway, thank you for the help uckelman.

Thanks,

Thus spake “FRCA”:

Someday we’ll add a global preference for setting the default max heap,
but we have a lot of things in the queue ahead of that right now.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)