module initial window size

Vassal 3.5.8
OSX 10.16
module CaseBlue_GBII_v6_07.vmod

I have a problem with a game in progress. When I load a vlog or vsav file the initial window displays as a single line compressed menu bar in the upper left-hand corner of the monitor. This problem only evidenced itself after the update to 3.5.8. In versions 3.5.6 and 3.5.7 the game window opened as it was last displayed.

However, now that this issue has occurred it persists regardless of the version of Vassal I use to open the vlog or vsav file.

I have not tried to start a new 3.5.8 game with this module, yet. I will try that tonight. I also have not tried opening the vlog on a different system. I will try that later as well.

Would you post a screenshot of what you’re seeing?

I will tonight.

Look in the extreme upper left-hand corner below the apple icon.

My guess is that you have a bad setting for the window size in your preferences file for the module.

Look for a file with the name of your module in ~/Library/Application Support/VASSAL/prefs. You should find in it a list of key-value pairs, one pair per line. Do you see any that start with “BoundsOf”? If so, would you paste them here?

I will do that tonight.

These are all the lines beginning with BoundsOf:

BoundsOfAxis\ OOA\ Jan-Feb\ 1942=570,570,0,0
BoundsOfAxis\ OOA\ Dec\ 1942=870,870,0,0
BoundsOfSoviet\ OOA\ Aug\ 1942=150,150,0,0
BoundsOfAxis\ OOA\ Blank\ Page=480,480,0,0
BoundsOfAllied\ Divisions=330,330,0,0
BoundsOfSoviet\ OOA\ April\ 1942=30,30,0,0
BoundsOfAxis\ OOA\ Mar-Apr\ 1943=960,960,0,0
BoundsOfSoviet\ OOA\ Nov\ 1941=1080,1080,0,0
BoundsOfSoviet\ OOA\ Nov\ 1942=240,240,0,0
BoundsOfAxis\ OOA\ Feb\ 1943=930,930,0,0
BoundsOfSoviet\ OOA\ Dec\ 1942=270,270,0,0
BoundsOfSoviet\ OOA\ Dec\ 1941=1110,1110,0,0
BoundsOfAxis\ Divisions=300,300,0,0
BoundsOfAxis\ OOA\ Nov-Dec\ 1941=540,540,0,0
BoundsOfAxis\ OOA\ May\ 1942=660,660,0,0
BoundsOfAxis\ OOA\ May\ 1943=990,990,0,0
BoundsOfSoviet\ OOA\ Oct\ 1941=1050,1050,0,0
BoundsOfSoviet\ OOA\ Sep\ 1942=180,180,0,0
BoundsOfSoviet\ OOA\ Oct\ 1942=210,210,0,0
BoundsOfAllied\ Supply\ Dumps=450,450,0,0
BoundsOfAxis\ OOA\ Nov\ 1942=840,840,0,0
BoundsOfAxis\ OOA\ March\ 1942=600,600,0,0
BoundsOfSoviet\ OOA\ June\ 1942=90,90,0,0
BoundsOfSoviet\ OOA\ Feb-Mar\ 1943=330,330,0,0
BoundsOfAxis\ OOA\ April\ 1942=630,630,0,0
BoundsOfSoviet\ OOA\ May\ 1942=60,60,0,0
BoundsOfAxis\ OOA\ Oct\ 1941=510,510,0,0
BoundsOfAllied\ Offboard\ Boxes=1538,187,382,469
BoundsOfAllied\ Dead\ Pile=417,151,498,626
BoundsOfSoviet\ OOA\ Jan\ 1943=300,300,0,0
BoundsOfSoviet\ OOA\ Jan\ 1942=1140,1140,0,0
BoundsOfAxis\ OOA\ July\ 1942=720,720,0,0
BoundsOfRail/Sea\ Cap=270,270,0,0
BoundsOfSoviet\ OOA\ July\ 1942=120,120,0,0
BoundsOfAxis\ Offboard\ Boxes=180,180,0,0
BoundsOfAxis\ OOA\ Sep\ 1942=780,780,0,0
BoundsOfAxis\ OOA\ Oct\ 1942=810,810,0,0
BoundsOfSoviet\ South\ Edge\ Box=360,360,543,374
BoundsOfAxis\ Dead\ Pile=210,210,0,0
BoundsOfAxis\ OOA\ Aug\ 1942=750,750,0,0
BoundsOfAxis\ OOA\ Jan\ 1943=900,900,0,0
BoundsOfSoviet\ OOA\ Apr-May\ 1943=360,360,0,0
BoundsOfSoviet\ OOA\ Blank\ Page=1020,1020,0,0
BoundsOfSoviet\ OOA\ March\ 1942=0,0,0,0
BoundsOfAxis\ OOA\ June\ 1942=690,690,0,0
BoundsOfAllied\ Set\ Up=150,150,0,0
BoundsOfAxis\ Supply\ Dumps=420,420,0,0
BoundsOfAxis\ Set\ Up=240,240,0,0
BoundsOfSoviet\ Front\ Reserve\ Box=390,390,0,0
BoundsOfSoviet\ OOA\ Feb\ 1942=1170,1170,0,0

What do you have for mainWindowWidth and mainWindowHeight in the V_Global file in the same directory?

mainWindowHeight=23 mainWindowRemember=true mainWindowWidth=80

mainWindowHeight=23 and mainWindowWidth=80 are your problem. Delete those two lines when VASSAL isn’t running, and then start VASSAL.

Window size problem fixed. Thank you. Although I do not know how that setting was created. I never use a map window that small.

However, something else has occurred that I never before encountered.

Today, part way through a move (same game module CB/GBII 6.07), the mouse could not put selected pieces from the main map onto an off-board map. When I tried to repeat the placement the pieces dropped through the off-board map onto the main map. When I tried to move the dropped pieces on the main map the mouse could not select them. I closed the off-board map and reopened it. This did not change the program behaviour. I then minimized the main map window only to discover that I could no longer select anything on the task bar. Nothing at all would respond until I forced Vassal to quit.



If you can give us steps for reproducing the problem, that would be helpful.

I will try should the occasion arise. However, that particular problem has never happened before so I cannot be certain whether or not it will happen again. I reported it in case someone else runs into something similar.