...not a valid VASSAL module.

Some mods I have downloaded appear to be not a VASSAL mod.(Alexander at Tyre, Empire in Arms, A fearful slaughter).
How can I change them into a readable format for VASSAL ?

Sandy

Some of the downloads have the *.mod file zipped. You need to unzip the mod or vmod file from the zip file.

Keith

I had a similar problem with I think Shifting Sands. In that case the file was zipped but the file had an incorrect extension. I was able to fix it simply by adding the .zip extension to the file. I haven’t tried any of the files you mention ktodd but that might also be the case with one or two of them.