Pieces not moving...help!!

I downloaded latest VASSAL and loaded the new Barbarossa to Berlin module from GMT games. Designer says everything works OK but this is the problem I have.

I log in for a solo game (new game) and start a logfile. I move loads of pieces around then I end the logfile. I then start a new game (offline) and login as solo and load the continuation file. The system reports the moves textually but no pieces are moved at all…can anyone tell me what I am doing wrong as the module designer cannot duplicate the problem…

Did the designer use your logfile?

  • Michael

2009/2/27 andyinkuwait <messages@forums.vassalengine.org (messages@forums.vassalengine.org)>

Post generated using Mail2Forum (mail2forum.com)

When I sent the logfile to hime he definitely saw all the pieces move as reported in the textual information. I , however cannot see this at all. Is it something to do with passwords?

Are you using the latest version (i.e., 3.2beta8) ?

2009/2/27 andyinkuwait <messages@forums.vassalengine.org (messages@forums.vassalengine.org)>

Probably not.

  • M.

Post generated using Mail2Forum (mail2forum.com)

I have 3.1 beta 8 can you tell me link for 3.2 beta 8?

On Feb 27, 2009, at 11:39 AM, andyinkuwait wrote:

That was a typo. The latest is 3.1 beta 8.

Work on 3.2 hasn’t really started yet.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

2009/2/27 andyinkuwait <messages@forums.vassalengine.org (messages@forums.vassalengine.org)>

Sorry, that’s what I meant. Got ahead of myself there.

Your problem is quite strange and I’ve never heard anything like that before.

This is just a hunch, though: try minimizing and then maximizing the player window after you’ve stepped through the moves. Have the pieces changed position?

  • M.

Post generated using Mail2Forum (mail2forum.com)

No change. I might try reinsatlling VASSAL…its clearly not a logfile writing problem as others can read the file so maybe its a read problem. Strange it should just be on this module though. Maybe I should delete all evidence of this module…before I start again…I’m convinced its me messing with passwords in order to simulate two players that caused the problem…

Reinstalled VASSAL no change

Tried deleting all other VASSAL files on machine from previous versions of VASSAL. No effect only happening in this module. Must be a password issue of some kind.

Would like to reload module as if it hasn’t seen it before… where it asks you for a password before choice of sides…what do I need to delete to do this?

2009/2/27 andyinkuwait <messages@forums.vassalengine.org (messages@forums.vassalengine.org)>

That still wouldn’t explain why others can use your logfile with no problem.

I’m at a loss to explain your problem. Anyone else?

  • M.

Post generated using Mail2Forum (mail2forum.com)

Tried deleting module and re downloading…no effect. Tried reinstalling VASSAL no effect. Where is the information about the modules stored on the computer? If I delete that…at least we are starting from scratch. I don’t mean the file with all modules in…I mean the info about passwords that VASSAL knows on bootup of the module.

Otherwise I am at a total loss particularly as this is the only module that this is happening…

Its annoying because it means I cant play solo very easily without a logfile of what has happened.

HELPPPPP PLease

Is it possibly a screen-refresh problem? Try clicking somewhere on the map after each move to force the map to refresh.

rk

Post generated using Mail2Forum (mail2forum.com)

No tried this. Old playback files before I changed the password play back fine perhaps someone could send me a logfile that they have generated just some simple moves from setup and I will try to play that back. If it works I know its something to do with how my sytem reads its own files…

More investigations…the played back logfile records combat markers added to the board, control markers, move markers but not unit moves on the board (although textual reports are fine). Why will it only playback moves by markers and not apparently recognise units at all??? It will even correctly record move markers moved from one place on the board to another with no problems…

What is going on here???

Quick question Andy… Exactly which menu item are you using to load the log file? Is it “Load Continuation” by any chance?

Wouldn’t surprise me if it is, that thing has been confusing Vassal users since the dawn of time. :slight_smile: The first thing you should do when the module loads is choose “Load Game” and choose the logfile, nothing else. “Load Continuation” is really a module designer’s tool and probably shouldn’t be in the Player at all.

Thanks for this now perfect. OK so simply load the logfile and it will start from where the logfile starts. Does this mean strings of logfiles cannot really be used to sort of get a replay of the entire game?

I had been doing this with at least two modules I’m sure using load continuations…

For load continuation to work you’re probably putting some faith in pieces starting where they should be starting. You need a perfect snapshot before you start stepping through and all sorts of things can muck it up; You really need to know what you’re doing.

I’m no expert on Load Continuation, some of the others may chime in with more info; But unless you know what you’re doing it’s best to leave it alone. I certainly wouldn’t be using it in the normal course of PBEM! It’s a big red button to the gates of hell. :laughing:

I just do not understand how to use VASSAL for PBEM with CDG.

If I send the logfile and my opponent opens this as a saved game (as suggested) he will be able to see my hand of cards but not his own because he has essentially loaded my game up. So how does he now play his own hand or indeed deal himself cards? He can also see my hand…

Where am I going wrong?

Which module are you using Andy?

On 2/03/2009 at 10:18 PM andyinkuwait wrote:

It sounds like you both have the same password set for this module, so Vassal thinks you are both the same player.

B.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Unless he’s assuming his opponent will see his cards? This is often the case because users do not understand that it’s password dependent. i.e. they load up their own game and see their own cards, therefore they rightly assume their opponent can see them too.

I wonder how we can make this process more transparent.