Pieces Stuck with No Map

Quick Summary: I have saved game (vsav) files that when refreshed to a new module version give a large number of ERROR Can’t Refresh Piece abc: No Map. I am looking for a way to get rid of these “No Map” pieces. (The game already has a very large number of pieces – extraneous pieces are bad.)

As I edited my module to new versions, I added new chart maps and deleted old chart maps.

I kept saved game files (vsav) compatible by creating a conversion module that had both the old and new chart maps. I would open the vsavs in the conversion module, move pieces from the old chart maps to the new chart maps and save. Then I would open the intermediate vsav into the new module and save again. All the pieces were now on the new chart maps and all was good.

However, some tricky players had moved (shoved??) many pieces outside the boundaries of the old chart maps. (Vassal will let you do that – zoom way out and move pieces off the board edge – not good.) I did not know they had done this, and did not capture and move these pieces from the old chart maps to the new. So they were left on the old chart maps, which now do not exist.

I can find the pieces in a Game Piece Inventory Window, showing a blank location. But, the delete command and send to location commands are grayed out and cannot be executed. I tried putting the old chart maps back and I tried opening the vsav files in the old module. Neither works. Apparently their location is recorded as blank in the vsav so it will not put them back on the old chart maps even if they are present.

Anyone know how I can remove these No Map pieces from the vsav files?


Tom W

Obviously no response as yet. I also have this issue, but I have not deleted, changed the Map is question. It may have been updated at some point with a new image, but that may be all.

Perhaps I’ve had this issue for some time now, but never noticed as I do not access the error log that often. Only when the piece updater runs and it reports not finding a game piece. One needs to then look at the errorlog file to determine what this (these) mystery game piece(s) is(are).

As for getting into the vsav files, I wish you luck. Apparently these are zipped and encrypted. The first is easy to resolve. The second is essentially impossible unless you know the encryption key, or how it is generated, etc. I, for one, would dearly like to know.

Using Vsav’s from older versions of module is, as you have clearly discovered, “scary”. I personally usually just go with “nope, not compatible, wait until you start your next game before pulling down the cool new version”.

BUT, if I were going to try to recover your or delete your off-map pieces, some things you could TRY are…

  • Open the files up in the OLD version of the module and see if you can move the pieces back and re-save?
  • Send a “CTRL+D” to them with a Global Key Command - it’s the most common keystroke for “Delete”, so they might delete themselves if their original definitions included a delete functionality.
  • Look at the original definitions of the pieces/prototypes in the old version of the module – do they have some OTHER functionality that you could activate with a Global Key Command … e.g. “move to” some specific place, etc?

But mostly… “Old Vsavs w/ New Modules” == “Scary”!


To palad0n – the encryption on vsavs is generated by “Obfuscator.java” in the Vassal open source. It’s only intended to prevent “casual” cheating and after all the source is right up. So in theory it is possible to write an app to de-obfuscate a file, then hand edit it, then re-obfuscate it so that Vassal will read it again. Doesn’t sound like much fun to me!