Pixel Tactics 0.2, 03 - umm, does either work?

New to VASSAL and excited to play P2P games.

Connecting via P2P works fine (apparently). Except dealing cards and actually seeing my hand in Pixel Tactics is a full-on mystery.

I’ve tried the 0.2 and 0.3 versions of Pixel Tactics.

When playing locally, I open Red Hand and drag cards into the hand window, I do not see the card faces, only the backs. No matter what right-click menu options I try.

This youtube user conveniently starts with his hand already set up. Hmm. https://youtu.be/ZHet__OHNoM.

When “playing” in a connected P2P session, Red Hand window won’t even open.

Running VASSAL 3.2.15 and Java 1.8.0_31.

Some other module I can download to actually see this promising framework in action?


Hmm, in P2P games, should I be creating a new room in order for the games to kick off properly? I don’t get any dialog that let’s me do that.

(Also tried Knizia Samurai, and the second player cannot take their turn, even after player one clicks End Turn)

Or, any backwards compatibility issues with modules?


Yes, yes they do work. Thanks for your patience.

Couple of noob issues going on…

  • Noob to Pixel Tactics, so the meaning of “Flip” and “Kill/Revive” as ways to toggle card orientation and facing threw me off.

  • Noob to VASSAL, so the notion of players joining in the P2P Main Room yet each player having to launch a “New Game” (to choose sides). Essentially each player playing their “own game” but the 2 games synchronized via the Main Room. Also threw me a bit :wink: