Play Sounds

Is there a trick to using the Play Sound trait? I only have one small 4K .wav file that I want to play when the user presses CTRL-S (the “fire” command in my module). I added the Play Sound trait with all this information but no luck. Do I have to turn this on in the preferences somehow? And yes, my speakers are turned on!

Hi,

No, it should work. I have just double checked and playing sounds does work in 3.0.17. There may be something in the setup of the counter that is preventing this from working.

Have you tried creating a basic counter that does nothing but play a sound? Does this work?

If you can’t work it out, send me the module, or a link to it and I will have a look.

Regards,
Brent.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Well that’s strange…the .wav file I initially picked doesn’t work, but I just tried a different one and it works fine. Guess I’ll go with the one that works!

I’m not sure if this is already answered in other posts… but actually it seems that VASSAL only works with certain WAV sound formats (not all configurations are valid), for me it works fine with 8bit 22khz mono clips.

You can easily convert wav files with the standar windows sound-rec aplication (sndrec32.exe), just “save as” with 8 bit, 22khz, mono, settings.

Hope that helps :slight_smile: