Problems with sub windows under Java ver. 8

I recently installed Java version 8 on my Mac. Since then I have found two problems with sub-windows: if you have more than one sub-window open at a time and activate one of them, the others disappear until you de-select the active window and activate the main game window. The other problem, which is more serious, is that you can no longer move counters between sub-windows and the main game map. This is a problem for games where the sub-windows represent cards in the boardgame that are used to hold pieces temporarily. I have found that Alt + mouse click will let you move pieces from the map into the sub-window, but the same combination will not let you move them back out again. Thanks for your assistance.

            Bob Williams

I have the same problem on my Mac. Secondary windows will disappear when they lose focus. Can not drag counters or cards from a secondary window when it’s over the main map window – when I move the window next to the main window, so they don’t overlap, then I can drag items back to the main window. No errors in the Error log. Pieces will move inside their own secondary window, but they will not ‘ghost’ while dragging.

I installed a clean OS X 10.11 in a VM with the latest Java 1.8.0_121 and it worked fine.
I updated the OS to macOS 10.12 and it no longer worked. Older versions of VASSAL (3.2.16, 3.2.15) which definitely were ok before also exhibit the problem on macOS 10.12, on my iMac and my MacBook Pro. So some change in macOS 10.12 must be causing this.

Edit: another interesting observation. When I defocus my VM machine window, and directly drag the card from the secondary window inside the VM window to the main map window, then it will ghost and drag properly. Really strange.

This video shows the dragging problem when the windows overlap (VASSAL 3.2.17, Java 1.8.0_121 in macOS 10.12):

A workaround that works for me in multiple modules is to turn off the “combined application window” setting.

I can confirm this workaround. Of course windows like hand windows with cards will layer underneath the main map window, which means you have to arrange them side-by-side to be able to drag for example cards from the main deck to your hand, which makes it pretty much the same workaround. But maybe it’s useful info for finding the bug.

The windows dragging issues seems to be fixed with the Java 8 131 update.

Still seems to be happening for me in combined mode :frowning: I verified the version manually and made sure is using this binary first.

$ /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
java version “1.8.0_131”
Java™ SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot™ 64-Bit Server VM (build 25.131-b11, mixed mode)

Yeah, I just tried with 131 JDK on my other Mac and got the problem still. I see what happened, after the update it reverted back to Java 1.6 due to my custom launch file. Spoke too soon. :frowning:

On the plus side, it’s pretty easy to download the 112 JRE zip file from Oracle, unzip it, and make use that one instead. Then anything else can use the latest JRE and Vassal still works.

It’s really disappointing that 131 didn’t work, because they even refer to MacOS UI problems in the readme.

I had the same issue. I unchecked the option «Used combined application window», restarted. That solved the issue.