Refresh Counters not working

I am trying to learn about Refreshing Counters. I open a game saved in a previous version of my module (VASL). I open the Refresh Counters dialogue box and select Run. I get the following error regardless of which combination of options I have selected in the dialogue box.

  • Unable to run Refresh, module was saved with older vassal version. Edit and save module with latest vassal version first.

I have opened the latest version of my module (which was built using the latest version of VASSAL) from the VASSL window.

As per the instructions in the error message, I have opened my module using Edit, made a small change and then saved it, all with the latest version of VASSAL.

I get the same error message.

I am sure that I am not understanding what Refresh Counters is supposed to do nor how to use it properly. Any suggestions as to where I am going wrong?

I can find no VASSAL Help about Refresh Counters. Probably looking in the wrong place.

What version of Vassal and what version of VASL are you using?

VASL6.6.3beta7 and VASSAL3.5.8.

Firstly, I would not advise editing and saving VASL using version 3.6 at this time unless there are specific 3.6 components that you want to add to the module. Once you save the module using v3.6, it will no longer be usable with Vassal 3.5.8. A version of VASL saved using Vassal 3.5.8 should run happily on both v3.5.8 and v3.6.

When you edit the module, do you get any messages like this:
but saying about ’ xxx GPID updated from y to z’? These indicate that the GamePiece Id’s in the module are incorrect and have been updated. Saving the module, then re-opening it should then allow you to refresh a save game.

See the discussion here Help! Fixing save files with bad PieceIds - #3 by Brent_Easton about how the Refresher works.


Thanks for your comments.

I have only seen beta versions of 3.6 so have not been using it but thanks for the heads-up.

When I make a change to a counter using editor and save the VASL mod, this is the only message I get:

  • !Module saved: vasl-6.6.3-beta7.vmod

I will read you post about refresher.


I have read the post on PieceIds. Thanks.

I don’t seem to be even getting to the point where Refresh checks PieceIds. I seem to get bounced right at the outset with this message about “Unable to run Refresh, module was saved with older vassal version.”

Can you point me to where Refresh exists in the VASSAL source code so that I can see if I can figure out what is causing this version mismatch?


Does this module have an extension loaded? If so, that might be the cause.

1 Like

Yes, that could be a problem. That specific message message you reported come from GameRefresher:243 when the GpIdChecker finds that the Gpid’s in the current module plus extensions have inconsistencies.

The Gpid’s can be cleaned by editing and saving the module or extensions that is causing the problem.


That was it. Had about a dozen extensions loaded . Soon as I removed them, Refresh worked.

Thanks to your both for your help.

1 Like