Runs once... then nothing... Windows 8.1


I have an odd problem. First time I run Vassal - runs flawlessly. However, if I close the app and try to reopen it - nothing happens. It doesn’t show up in my task manager either.

The only way I can get it to work again is to restart the computer.

Any thoughts?

Other solution is to just keep Vassal running full time! :mrgreen:

Also - I see no log file that would help ID the issue…

Unless it’s kept somewhere outside of my Vassal folder and My Documents… Cannot find it!

First up, you need to try and identify which install of Java you have on your system–and make sure there aren’t multiple ones. Ideally you want to get down to a situation where you have only one Java install, and it matches your operating system (i.e., 32-bit Java for a 32-bit OS, 64-bit Java for a 64-bit OS). This may require uninstalling Java(s) completely, rebooting, installing the correct one, and rebooting.

Your errorlog will be found in C:\Users[i]your username here[/i]\AppData\Roaming\VASSAL

This is very likely a hidden folder by default, so you will need to set the Windows explorer to show hidden files or navigate there manually.

Ok - my java was remarkably out of date. (I am on a new computer - just got a Surface Pro 3 for work… didn’t think to update Java.)

I’ll give that a shot - I tried - but I need a restart I’m sure.

Perfect - that was all it took!

Thanks for the quick reply - appreciate the help!