Scrolling refresh problem with Mac OS 10.11


I have a problem when I scroll a map on my Mac (please see this image):


Basically, when I scroll a map (it happens with every module I use) it gets casually tiled until I click on the screen; sometimes it refreshes without intervention after 10-15 seconds. A similar problem shows when the message list scrolls automatically up for a new message; tipically, this message covers the last one until I scroll manually.
This behaviour is the same with different versions of Vassal (I tried from 3.2.14 to 3.2.17 and also 3.1.20) and with different versions of Java, too (both 8 and 9 by Oracle and the legacy version 6 by Apple). I’ve also tried an higher heap size to no avail.

Thanks to everyone which can help.

Is there anyone with the same problem?

Thus spake gcallari:

Is there anyone with the same problem?

If you search the forum, you should be able to find quite a few
Mac users who have had display problems. Some have found that it
happens for them only with certain versions of Java or only with
certain versions of OS X.


I had the same problem, and it’s related to the version of Java loaded. Java 8 (and probably 7 too) works fine, but 6 gives these graphical glitches. You should check the Error Log in VASSAL > Help Menu > Show Error Log.

2016-09-09 22:29:38,217 [0-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.12 2016-09-09 22:29:38,218 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_101 2016-09-09 22:29:38,218 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.16

This shows it’s loading Java version 1.8 (8), so that is ok. If it says 1.6 then it’s loading the old one, which causes these graphical glitches.

On the computer where it doesn’t work it has a java on one of these paths:

/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands/java /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Commands/java /Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Home/bin/java
Probably something left over from some old installation on an older OS X?

On the computer where it works it does not have java on those paths, and instead uses the:

JAVA="$(which java)"

Which finds java on /usr/bin/java, and works just fine.

Many thanks bdgza and uckelman,

it seems the problem was exactly a lingering 1.6 version. I’ve had to remove manually the old jre. If anyone has the same problem, here is a step-by-step tutorial: