Startup error in Fedora

Hi, my name is Riccardo, I would run vassal on a Linux Fedora 33 but I get the following error:

Exception: java.lang.NoClassDefFoundError thrown from the UncaughtExceptionHandler in thread "main"

I see my machine run java 11:

$ java --version openjdk 2020-11-04 OpenJDK Runtime Environment 18.9 (build OpenJDK 64-Bit Server VM 18.9 (build, mixed mode, sharing)

I’m not expert in java so I am not able to handle this exception by my own, can you help me to fix it? Should I upgrade some further informations?

Hope you can help me

All the best

What version of VASSAL are you using? How are you running it?

I use VASSAL 3.4.8. To run it I try both to create a shortcut icon on desktop and to run it from terminal using the following command from within the VASSAL directory: :~$ ./ These are the permission of the script: -rwxr-xr-x. 1 r r 1494 Dec 18 11:36 I also tried to esplicitly invoke bash: :~$ bash ./ but I get the same error.

  1. Is there more output when you get that error? There should be a stack trace.

  2. Please try 3.4.11.

Hi, using the 3.4.11 all seems to work… Thanks!