Sudden unresponsive windows and/or board

Dear All,

I run Vassal 3.2.13 on Ubuntu 12.04 LTS with Java 7. I’ve got a strange problem that appears to reoccur rather randomly.

Basically, sometimes individual windows but also the game board, and all associated controls and menus, suddenly become unresponsive. That is, I cannot click e.g. the zoom buttons, I cannot activate a piece and I am thus no longer able to move pieces within or out of the window or the board. When I click a window that has become unresponsive like that, it flashes as if being selected for a fraction of a second, and then it goes unselected again.

Strangely, I am able to move pieces into that unresponsive window/board in which case the window/board becomes responsive again. It is thus not that the whole of Vassal freezes, but rather individual windows do.

The problem is not specific to some particular module. Also, I don’t know if this is relevant, but this problem has occurred both as I open a module and play it as well as when I edit a module and go on to play the changes I have made.

Perhaps I also should mention that on my desktop I’ve still also got the Vassal 3.2.11 folder kicking about as some stuff related to a module I have been working on is located there. I figured this would not cause conflicts because, as far as I can see, Vassal is not installed as such but runs from the file, as it were.

Any idea what this might be all about?


I’ve had that happen and I discovered that the flash you’re seeing is actually the window opening but it is opening in a non-viewable area. What I do when that happens is open another window of some kind (like notepad) and then right-click the taskbar and tell the windows to tile vertically or side-by-side. That will bring the window up and it will behave normally after that.

Thanks for your 2 cents! I wonder if we have been having the same issue though as it sounds like your “unresponsive” window disappears from view, while with me the window is there to see all the time. It’s just that nothing can be done with it.

My situation with the unresponsive map windows as described above continues to bug me.

I have began to think this is a problem (perhaps Java related?) in Ubuntu rather than a problem with Vassal. I have realised that when I run Vassal all on its own without any other programme running the unresponsiveness does not occur. Also, sometimes when I run Vassal and a programme named Texmaker both at the same time I have noticed that some features of Texmaker do not work while i am having unresponsiveness isssues in Vassal. Surely this means there is a conflict of some sort here between the programmes? Can anyone think of a way in which Vassal might conflict with some other running process like this?