Synchronizing Broken? - 3.2.1

Me and my friend cannot Synchronize with each other in the current version of vassal, the auto synchronizing happens and says its complete, but the game never shows up.

If we try to manually right click and Synchronize, nothing happens and the option becomes greyed out.

We’ve tried it both ways, both of us starting new rooms, new games, with two completely different modules.

We are both using Vassal Version 3.2.1.

My specs are in my sig, my friends specs:

  • Model: Custom Build
  • Operating System: Windows 7 64 Bit
  • CPU: 3.30 GHz
  • Memory: 8GB
  • Video Card: Radeon HD 6800
  • Vassal version: 3.2.1
  • Java: Version 7 Update 9

Same here.

Thus spake reddeblu:

Me and my friend cannot Synchronize with each other in the current
version of vassal, the auto synchronizing happens and says its complete,
but the game never shows up.

If we try to manually right click and Synchronize, nothing happens and
the option becomes greyed out.

We’ve tried it both ways, both of us starting new rooms, new games, with
two completely different modules.

We are both using Vassal Version 3.2.1.

Did this work for you with 3.2.0?


J.

Yes I just checked to be sure and Auto Synchronizing on joining a room works perfectly fine with us in 3.2.0.

Thus spake reddeblu:

Yes I just checked to be sure and Auto Synchronizing on joining a room
works perfectly fine with us in 3.2.0.

This is likely due to the fix for Bug 9600. I’m looking into it now.


J.

Thus spake reddeblu:

Me and my friend cannot Synchronize with each other in the current
version of vassal, the auto synchronizing happens and says its complete,
but the game never shows up.

If we try to manually right click and Synchronize, nothing happens and
the option becomes greyed out.

We’ve tried it both ways, both of us starting new rooms, new games, with
two completely different modules.

We are both using Vassal Version 3.2.1.

I believe I’ve corrected the problem. Please try 3.2.2-svn8486,
available here:

vassalengine.org/~uckelman/builds/

Let us know as soon as possible if this corrects the problem for you,
as this is a severe bug, and I’d like to release 3.2.2 right away if
the fix is effective.


J.

The fix has worked, we are able to synchronize again with 3.2.2-svn8488. Everything seems to be working, Auto Synchronization on joining a room went off without a hitch.

I would just like to add, again, a big thank you to the vassal developers for their hard work and dedication, and very very quick bug resolving! (Especially Brent)

Thanks to all your efforts I was finally able to finish my module and it works great! Vassal is an amazing program with amazing people behind it, thank you all.

Thus spake reddeblu:

The fix has worked, we are able to synchronize again with 3.2.2-svn8488.
Everything seems to be working, Auto Synchronization on joining a room
went off without a hitch.

Great. Thanks for checking. The problem was that when we switched base64
encoders in response to a different bug, I misread how the interface for
the new one worked, which caused it to produce results other than what
the game server was expecting.

The fix will be in 3.2.2, which we’ll release shortly.


J.