I was trying for the first time my module online. I tried both peer-to-peer and server mode with my desktop and my laptop,
both connected to the same modem-router and using the exact same version of Vassal (1.3.18) and of the module.

However, I must be doing something wrong, because when I have both computers joining as Jack and John, as soon as
Jack starts a game and John wants to syncronize with it then John will get a messed up screen.

Things that show on Jack’s display won’t show on Johns. Pieces that are underneath others in Jacks are instead visible
in John’s etc.

What am I doing wrong?

I have seen this ocassionally, and quitting out of Vassal then rejoining/resyncing has fixed it. Is this reproducible?

I tried quitting/rejoining/restarting many times. Always same problem.

Might it be router related?

Or maybe I don’t know how online games really work on Vassal. I am starting a room with Jack, inviting John in (if peer-to-peer), then Jack starts the game. What has John to do? Start then synch? Only synch?

I tried both ways. I also tried John starting his own version of the game, without resynch. For a while both screens seem to refresh right, but then pieces unmasked or moved by Jack won’t show on John’s side.

P.S. Would you be willing to spend like 10 minutes to test it out with me? :slight_smile:

Sigh, I tried online with somebody else and serious synching problems. No problems when I try offline but completely unplayable online.

Any idea?

John should only need to synchronize with Jack. Try peer-to-peer with your local IP, same problem? Do you have the same problem with other modules?

I played a game of Smallworld a few weeks ago and, afaik, there was no problem.

My module is rather complex, I guess. I never thought to try it online before, concentrating on having it run without problems offline.

However, the problems I noticed yesterday are very serious: pieces showing which should be covered by others, pieces not showing at all, send to locations working on the “host” screen but pieces disappearing on the “client” screen etc. This is all very distressing after months of work and I don’t know where to start fixing it. Remove piece by piece? Trigger by trigger?

Any expert online player who can help me out trying it with me to see the problems I am talking about, please?