Translations in Game Piece Pallettes not working?


I just spent about 20 hours translating a Vassal module from Italian to English. The translations in game piece palettes don’t seem to actually have any effect though. I set the language for the translation to “English/Any Country” and my language preference in Vassal is set to “English”. Almost everything I’ve translated has worked, except for text within game piece palettes. Any ideas?

Here’s a link to the module I’m translating:

If you click “Heroes” or “Monsters” on the toolbar you see Italian text in the palette, even though I’ve defined all of the translations (painstakingly).

Okay, unzip the module, look for Italian phrases in “buildFile”, and use this script:

#!/bin/sh export IFS="," awk '{print $0}' modulestrings.txt | while read a b do sed -i '' "s/${a}/${b}/g" buildFile done

You’ll need to create a file called “modulestrings.txt” with this format

Vola via dal gioco,Retire from the game Contrassegna tutti i pezzi su questa mappa come non mossi,Mark all the pieces on this map as moved

In other words: Italian phrase on the left, English phrase on the right. Watch out for commas!

I appreciate the solution bugggg, but this means redoing a lot of the work I’ve already done. Is this definitely a bug with Vassal then?


It does appear to be a bug. I will see what I can do.


That’s great. Thank you Brent. I hope it’s something fairly straightforward.

Not too straight-forward unfortunately. Translations have never been applied to items in the Game Piece palette’s. I’m thinking we assumed this was more a module editing function than a module playing function. The editing side of Vassal does not support translations.

I’m looking into it to see if there is an easy way forward.


Has there been any update on getting translations working on game piece palettes? Thank you!

is there a fix ?



in following sections does the translation works corrctly (wht I have found in VASSAL 3.2.15):

  • Pieces - Trigger-Action
  • Piece-Palette - No Translation, pieces only shown with original name
  • HTML-Help - If translated, the Browser will not open

It seems this bug in Vassal has not yet been resolved with the current Vassal version (v3.5.:sunglasses:
I hope this old problem (from 2013) will be solved, eventually.
Thank you very much in advance.