trouble unzipping a module on Mac

Hey there folks,

I’m having trouble with the module Turning Point Stalingrad. I’m using a Mac. It appears to be downloading into a zip file onto my desktop, then expanding into a bunch of files that won’t open in Vassal.

I’ve tried the ‘save as…’ option mentioned in the FAQ, but to no avail. This is as far as my techie expertise goes I’m afraid.

Vassal itself is working fine. I have C&C:A and Breakout Normandy working. I downloaded everything yesterday so I’m a complete noob at this.

Any hints?

cheers, Blair

Thus spake “Blair”:

The TPS file on our site is a ZIP archive which contains the module. My
suspicion is that your browser us unzipping this archive for you, and that
what you end up with is a file called TPStalingrad.mod. This is the module.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Thanks for the reply…

I do not seem to have a file called TPStalingrad.mod amongst all of the other files that have been unzipped.

When I click on the zip file, it opens to a folder called TPStalingrad with numerous ‘htm’ & ‘gif’ files, a ‘buildfire’ & ‘info’ file, but not the mod file you specified.

I’ve tried opening all of these in Vassal, but I keep getting error messages.

I’m a bit stumped really. Would you have any other suggestions?

Blair

Thus spake “Blair”:

The file you’re clicking on is the module, then. (Modules are technically
ZIP files themselves.) Try opening that file in VASSAL.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

No dice I’m afraid. I’ve tried uploading that zip file using the ‘open’ & ‘import’ options in Vassal, I’m still receiving those error messages.

B.

Thus spake “Blair”:

If what you’re trying to load is a VASSAL module, then Import is the wrong
choice. Import is for converting non-VASSAL modules into VASSAL modules.

“Open Module” is the correct choice.

As for your other problem, we need a Mac user to help you with that.


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Yeah, I figured that, I’ve just been clicking and trying all the different options. Still can’t get it working, I tried the Field Commander Rommel module, and it’s not working either. At this stage my Mac is being completely arbitrary about what it is allowing to work.

Thanks for taking the time to reply, as I’ve just started dabbling in the program, it’s good to know there’s help. :slight_smile:

Thus spake “Blair”:

There are some suggestions for what to try on this thread:

vassalengine.org/forums/viewtopic.php?t=1854


J.


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Thank you so much for making the effort to help me on this issue.

I have tried all of the suggestions mentioned in the other thread. The module - TPStalingrad in zip form - will not work in Vassal. I have right clicked and have an unzipped TPS module currently on my desktop, but Vassal won’t recognize it.

I have downloaded Vassal 3.1.2 and I am running Mac 0S X 10.4.11. I am using Firefox to make the download, which is apparently the trouble free browser according to another thread.

The error message that I am receiving is that the (TPS Zip file) is not a valid vassal module. This is the same message I have received for Field Commander Rommel.

Maybe I need to update my OS?

On Apr 2, 2009, at 3:55 PM, Blair wrote:

No. I don’t think that is the problem.

As far as I can tell the real problem is that the standard Mac
unarchiving software is a bit too aggressive in decompressing the items.

The structure of this module is:

TPStalingrad.zip (a zip file containing one item):
TPStalingrad.mod (the module, which happens to be another zip file
with)
buildfile
images
etc.

So the top-level TPStalingrad.zip file is, correctly, not recognized
as a Vassal module. It needs to be unzipped, but just one level.
There are two ways you could go about this:

  1. The arcade game approach. If double-click on the file and look
    closely when the file is being decompressed, you will see a secondary
    progress-bar dialog where it is expanding (or decompressing or
    unarchiving) the TPStalingrad.mod file. If you can quickly hit the
    cancel button on the dialog before it finishes, then you will have the
    actual Vassal module that you need. It may take several tries to
    actually be able to stop it.

  2. Use Stuffit Expander. If you have Stuffit Expander, you can use
    that to only undo one level of compression. Right-Click on the module
    and choose “Open With” and then Stuffit Expander. I think 10.4 would
    have a version of Stuffit Expander installed. Otherwise, you can
    download that application from the publisher’s website my.smithmicro.com/mac/stuffit/expander.html
    (where you are forced to agree to receive EMail from them in order
    to get the free application) or you can get it without that step from macupdate.com/info.php/id/20954

  3. The Unix user approach. If you feel reasonably comfortable using
    the Terminal application ( Applications > Utilities > Terminal ),
    then you can use the Unix command line tool “unzip” to unzip the
    downloaded file. It will do only a single level, rather than
    “helpfully” also expanding intermediate files. You would navigate to
    where you have the zip file located and then unzip it. For example:

% cd ~/Desktop
% unzip TPStalingrad.zip

I couldn’t find the Field Commander Rommel module, but I suspect it is
a similar problem.

(I wonder if I should add this to the Wiki page as well?)


Messages mailing list
Messages@forums.vassalengine.org
forums.vassalengine.org/mailman/ … engine.org

Post generated using Mail2Forum (mail2forum.com)

Success!

I used the arcade, quick click approach. It did take me several goes, but my hand-eye-coordination is not what it used to be…

Thank you all for taking the time &trouble to help me with this.

cheers, Blair. :smiley: