Twilight Struggle Module not loading

First time I’ve tried to use Vassal, want to play Twilight Struggle but upon trying to load the module an error message appears stating ‘VASSAL had an internal error’. System details and error report below.

Does anyone have an idea why it isn’t working.

Cheers in advance.

Model: HP Pavilion 15 Notebook PC - n266sa
OS: Windows 10 Home 64-bit (10.0 , Build 14393)
CPU: AMD A8-4555M APU with Radeon™ HD Graphics 1.60 GHz
Memory: 8.00 GB (7.19 GB usable)
Video: amd radeon hd 7600g
VASSAL: 3.2.17
Java: 8.0.1210.13
Module: Twilight Struggle 3.1.2

2017-03-09 19:56:55,179 [0-main] INFO VASSAL.launch.StartUp - Starting
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - OS Windows 10 10.0
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_121
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17
2017-03-09 19:56:55,478 [0-AWT-EventQueue-0] INFO VASSAL.launch.ModuleManager - Manager
2017-03-09 19:56:55,963 [0-main] ERROR VASSAL.tools.ErrorDialog -
java.lang.NullPointerException: null
at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source) ~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2.access$400(Unknown Source) ~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source) ~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source) ~[na:1.8.0_121]
at java.util.concurrent.FutureTask.run(Unknown Source) ~[na:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[na:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Unknown Source) ~[na:1.8.0_121]
at java.lang.Thread.run(Unknown Source) ~[na:1.8.0_121]

Thus spake benmiller70:

First time I’ve tried to use Vassal, want to play Twilight Struggle but
upon trying to load the module an error message appears stating ‘VASSAL
had an internal error’. System details and error report below.

Does anyone have an idea why it isn’t working.

Cheers in advance.

Model: HP Pavilion 15 Notebook PC - n266sa
OS: Windows 10 Home 64-bit (10.0 , Build 14393)
CPU: AMD A8-4555M APU with Radeon™ HD Graphics 1.60 GHz
Memory: 8.00 GB (7.19 GB usable)
Video: amd radeon hd 7600g
VASSAL: 3.2.17
Java: 8.0.1210.13
Module: Twilight Struggle 3.1.2

2017-03-09 19:56:55,179 [0-main] INFO VASSAL.launch.StartUp - Starting
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - OS
Windows 10 10.0
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - Java
version 1.8.0_121
2017-03-09 19:56:55,189 [0-main] INFO VASSAL.launch.StartUp - VASSAL
version 3.2.17
2017-03-09 19:56:55,478 [0-AWT-EventQueue-0] INFO
VASSAL.launch.ModuleManager - Manager
2017-03-09 19:56:55,963 [0-main] ERROR VASSAL.tools.ErrorDialog -
java.lang.NullPointerException: null
at sun.awt.shell.Win32ShellFolder2.getFileSystemPath(Unknown Source)
~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2.access$400(Unknown Source)
~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source)
~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolder2$10.call(Unknown Source)
~[na:1.8.0_121]
at java.util.concurrent.FutureTask.run(Unknown Source) ~[na:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
~[na:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
~[na:1.8.0_121]
at sun.awt.shell.Win32ShellFolderManager2$ComInvoker$3.run(Unknown
Source) ~[na:1.8.0_121]
at java.lang.Thread.run(Unknown Source) ~[na:1.8.0_121]

This is a known bug in Java. If you search, you can find lots of cases
of people reporting it against applications other than VASSAL. There
isn’t much of anything we can do about it ourselves, as you can see from
the stack trace that it doesn’t involve any of our code. Nobody seems
to know what the causes is, let alone having any suggestions for a
workaround.

I have some suspicion that it’s due to a permissions problem. You might
check whether it works to run VASSAL using the admin account.


J.