Twilight Struggle: starting a new game

Hi, i’m italian and i’m finding a big problem starting games with other players (most of them italian like me).

I’m using the vassal version 3.1.18 on three different computers.
A desktop pc with win7 home premium SP1 and java 1.6.0_30
A netbook with same parameters
A notebook with winXP SP3 and same version of vassal and java.

Module of TS is the last one 3.0.10a

These are the steps i make:

  1. open a new room
  2. wait for my opponent to get in
  3. create a new game (standard with optional cards)
  4. choose the side
  5. tell my opponent to sync
  6. now comes the moment of truth: 2 times on 3 things are ok and we can play, sometimes instead my opponent has both cards icons inactive. He seems to be playing as an observer and can’t open his card’s window.
    From now on we can try everything on earth. One of two can see his own cards and the other can’t. Me and that player cannot play together. No matter which computer i’m using, home, office, around on the street.
    The only thing i noticed when I try to synch is two lines on the log saying “bad data on module”. No other specifications. And this is the same thing my opponent read when HE tries to sync me. But when i create the game i don’t see any error. Only during sync, the player synchronizing read the error.

That’s seems incredible that on 3 different pc i cannot play with a specific player.

Anyone else has my problem?

Thanks a lot for your help.

Y.

  1. now comes the moment of truth: 2 times on 3 things are ok and we can
    play, sometimes instead my opponent has both cards icons inactive. He
    seems to be playing as an observer and can’t open his card’s window.
    From now on we can try everything on earth. One of two can see his own
    cards and the other can’t. Me and that player cannot play together. No
    matter which computer i’m using, home, office, around on the street.
    The only thing i noticed when I try to synch is two lines on the log
    saying “bad data on module”. No other specifications. And this is the
    same thing my opponent read when HE tries to sync me. But when i create
    the game i don’t see any error. Only during sync, the player
    synchronizing read the error.

That error message shouldn’t affect play. There is something else going on
here.

There is, however, an issue if you have the default language set to
something other than English. I only know this as it has been reported to
me that there are strange problems when you have this setting. I’ve tried
it many times myself, but I’ve never seen the problem. Nevertheless, a lot
of other people have experienced it.

Try setting the default language to English. Let me know if this resolves
the issue – I would like to know either way actually.

Unfortunately, this is a problem I have never been able to solve (the
primary problem being that, for whatever reason, I have never seen it – it
may be some interaction between Java version, language, operating system,
etc., that I have yet to uncover).

  • M.

That’s seems incredible that on 3 different pc i cannot play with a
specific player.

Anyone else has my problem?

Thanks a lot for your help.

Y.

_____________**
Read this topic online here:
vassalengine.org/**forum/vie … 4#**p30954<https://forum.vassalengine.org/t/twilight-struggle-starting-a-new-game/4685/1
_____________**
messages mailing list
messages@vassalengine.org
vassalengine.org/mailman/listinfo/messages

It worked! :open_mouth: :slight_smile:

I set up language as english and i tried to start a game with an opponent that usually gave the problem. And it worked.

Thank you very much.

I will keep the situation updated when i will challenge other players.

Not the most satisfactory solution, but there you have it. TS uses a lot
of custom code and there is definitely something going on there. It’s
possible that the module is trying to translate something that is hard
coded into the module, but I’ve never found it.

One of these days…

  • M.

On 15 February 2012 17:13, yucatan yucatan.tango@libero.it wrote:

It worked! :open_mouth: :slight_smile:

I set up language as english and i tried to start a game with an
opponent that usually gave the problem. And it worked.

Thank you very much.

I will keep the situation updated when i will challenge other players.

_____________**
Read this topic online here:
vassalengine.org/**forum/vie … 2#**p31042<https://forum.vassalengine.org/t/twilight-struggle-starting-a-new-game/4685/3

_____________**
messages mailing list
messages@vassalengine.org
vassalengine.org/**mailman/listinfo/messageshttp://www.vassalengine.org/mailman/listinfo/messages

Well, i know how you feel.
Programming is a continuous search for perfection.

By the way, i’m getting hours of fun with TS on Vassal.

Thank you very much.