UI Issue X-Wing Miniatures Game, Hard to Describe

I want to preface this by saying I don’t get any errors. My first report is locate https://github.com/Mu0n/XWVassal/issues/271 and includes an image of the problem.

While playing a match, the map background will start to cover every screen and anything I do. It will spread to my player window and cover everything. The right click menu will be covered, but scrolling down through the menu exposes the options. It almost looks like the game freezes with the map background covering everything, but no functions are actually frozen and I can keep playing. Minimizing the screen resets the screen back to how it should look, but the problem comes back. I can’t figure out a trigger and once it starts, it won’t stop. It doesn’t happen in any particular screen until I click it and it doesn’t start happening right away. This has occurred consistently for weeks at this point. Uninstalling and reinstalling doesn’t fix the issue. Here are my specs:

Alienware Aurora R8
-Windows 10

  • Intel Core i-7-9700
  • 16Gb memory
  • GeForce RTX 2060 Super
  • Vassal 3.2.17
  • Java 1.8.0_261-b12)
  • Star wars X-Wing Miniatures Game 8.8.9

Is there any way this could be reproduced? Any particular sequence of steps that lead to this issue?

And, have you tried it with latest version of Vassal, version 3.3.2?

I need to give a go with the latest version. I have no idea how to reproduce it as it happens every time I play.

If it still happens with the latest version, try to narrow down the steps that make it happen. Does it happen after 5 minutes of playing? 10? Does it happen when you click something specific? Does it happen if you just load up the module then don’t do anything at all?

Still no luck with the latest version. The issue happened immediately. The first time I right-clicked on my ship in the map to open the shortcut menu, it started up. All I have to do is mouse over each window and the background changes as pictured. It’s so strange.

I have this same issue when I try to play the Xwing module, and it happens when I move the mouse cursor over the UI buttons of any of the seperate windows.

I tried playing with the latest versions, both X-Wing and Vassal, but the problem persists. It started early, after my first attempt to right click a ship to bring up the shortcut menu. Sometimes left clicking in the map would stop the issue for a bit, but eventually it would come back. Minimizing resets the view, but does not stop the issue. I have updated screenshots posted here: https://github.com/Mu0n/XWVassal/issues/271

I found this looooong thread about Xmage and it looks like the same problem.

github.com/magefree/mage/issues/1514

one fix from a 2018 reply seems promising “JayDi85 commented on 24 Feb 2018”:

"Set the global environment variable “J2D_D3D” to “false” inside the OS. According to Sun, this setting is used to turn off the Java 2D system’s use of Direct3D in Java 1.4.1_02 and later.

ie: simply create a environmental variable with name “J2D_D3D” and value “false” without the quotes."

That environment variable seemed to have solved OP’s original problem.

There should be an option named “Disable DirectX D3D pipeline?” in the global preferences, enable it, restart the module, and it should work from then on.

Confirmed, the disable DirectX option fixed the problem. Thanks everyone!