unable to drag and drop from windows

Since I updated to the new .17 version I am unable to drag and drop pieces from a menu window on the map
I installed the old version, but the problem persist.

What could be a solution?
Thank you

Using Sierra on a Mac with a recently updated JRE? Seems to be if the point you click on in the tool window is also over the main window, mouse events don’t get delivered properly. You can move the tool window to the side of the main window, or turn off combined window mode to work around the problem until whoever is responsible (probably Oracle or Apple) fixes it.

Thus spake DucaVassal via messages:

Since I updated to the new .17 version I am unable to drag and drop
pieces from a menu window on the map
I installed the old version, but the problem persist.

What could be a solution?
Thank you

Are you using a Mac?


I’ve encountered two Mac users who have this same problem. Is there a way to roll back to an earlier JRE that I could point them to?


-Joel Toppen

Thank you all for the quick responses.

Yes, I am using a Mac and it is indeed a Sierra OS on a recently upgraded JRE
I am not sure I know how to turn off the combined window mode (and what are the consequences of it).

oracle.com/technetwork/java/ … 39210.html

This starting point can be used to find older JRE releases. I don’t think downgrading is generally supported, so you’d have to go through removing the JRE and then installing the older one, and making sure automatic updates were disabled. The biggest deal there is obviously security, who knows what security flaws you might be adding back? But hey, who knows what unknown security flaws you are introducing with the latest version :stuck_out_tongue:

Thank you

Hope Apple/Oracle will address the issue soon


I had the same problem, and couldn’t use the trackpad shortcut (two fingers) to open contextual menus, too. I solved it reinstalling version 8u112 found above. Also, I uninstalled the latest version before installing the older one as detailed here:

java.com/en/download/help/m … l_java.xml

Thank you for posting that gcallari, I didn’t really have time to play “hunt the version that works”.

I can confirm the problem is still there, though in a somewhat different way ( I can use the contextual menus now, for example) with the last Java update (8u131). Unchecking the option «Used combined application window» and restarting, as indicated in another thread, solves the issue but then it is better to have a large screen to manage the multiple windows comfortably.

… And I spoke too soon. The problem with the contextual menus is still there even with no combined application window. Back to 8u112.

Mac user here, having the same problem. Very frustrating!

Just an update for Mac users, unfortunately latest Java release (8u144) has not resolved the issue. 8u112 is still the last working one.

I just tried with the latest pre-release version: 8u152 b05 from jdk.java.net/8/
on my macOS 10.12.6 computers with VASSAL 3.2.17.

It seems to work again. Perhaps someone can try to confirm?

2017-09-10 14:25:49,201 [0-main] INFO VASSAL.launch.StartUp - Starting 2017-09-10 14:25:49,205 [0-main] INFO VASSAL.launch.StartUp - OS Mac OS X 10.12.6 2017-09-10 14:25:49,205 [0-main] INFO VASSAL.launch.StartUp - Java version 1.8.0_152-ea 2017-09-10 14:25:49,206 [0-main] INFO VASSAL.launch.StartUp - VASSAL version 3.2.17

Downloaded Vassal again, can confirm that 8u152 does fix the drag/drop problem, but it still has the other annoying issue where cmd-` does not cycle through available windows, and instead swaps between the two most recently used. Very annoying.

8u112 is still the version I’d use because of this :frowning:

I didn’t even know about the cmd- bug. I do use cmd- (I get a US layout keyboard especially for it) but not in VASSAL I guess. I expect Java app interfaces to be horrible anyway.

To me the drag-and-drop bug is more important to be fixed, as it’s a crippling bug rather than an annoyance. And for less tech savvy VASSAL users on Mac it’s a turn off, they think VASSAL is broken and stop using it, whereas cmd-` is not very well known anyway.

I have a IMAC on OSX El Capitan and have seemingly the same problem as above. I can not move reinforcements onto the map, nor draw cards and put them in my hand. This is for PURSUIT OF GLORY 1.0.6. I downloaded earlier versions of the game and vassal and no luck. I have 8 G.B. so that should not be an issue.