Unable to Load and Run on 32 bit Vista

Howdy Gents,

Not supremely important to me, but could be useful. I do alot of my graphics design work using older Photoshop programs that run on my old Vista. It would be helpful if I could get Vassal to run on it too. It’s an old 32 bit laptop with 4 Gb RAM, and only 325 HD. But it gets the graphics work done with the use of an external.

I get the following Errors when I try to load and install 32 bit Vassal 3.4.12 and same when I try to run 3.1 win beta

The prodecure entry point K32EnumProcessModules could not be located in the dynamic link library KERNEL32.dll

Error: loading: C\Program
Files\VASSAL-3.4.12\jre\bin\client\jvm.dll

Now it will not kill me if I can’t get this to work, but it would be helpful.

Thanks,
Tom

Thus spake Cundiff:

Howdy Gents,

Not supremely important to me, but could be useful. I do alot of my
graphics design work using older Photoshop programs that run on my old
Vista. It would be helpful if I could get Vassal to run on it too.
It’s an old 32 bit laptop with 4 Gb RAM, and only 325 HD. But it gets
the graphics work done with the use of an external.

I get the following Errors when I try to load and install 32 bit Vassal
3.4.12 and same when I try to run 3.1 win beta

The prodecure entry point K32EnumProcessModules could not be located in
the dynamic link library KERNEL32.dll

Error: loading: C\Program
Files\VASSAL-3.4.12\jre\bin\client\jvm.dll

Now it will not kill me if I can’t get this to work, but it would be
helpful.

The bundled Java is Java 15. The earliest Java version you could use for
VASSAL 3.4 if you weren’t using the bundled Java is Java 11. Java 11
requires Windows 7 or later. You won’t find a build of Java 11 which
runs on Vista. There’s nothing we can do about this.


J.

Don’t know if I was using the bundled Java or not. If it loads automatically when you install 3.4.12 then it attempted it, but failed. Which version should run on Vista? I couldn’t get v3.1 to run.

To run version 3.2.17 of VASSAL or earlier, you need to install Java 8. You’re out of luck trying to run version 3.3 or later on Vista.

Thus spake Cundiff:

Which version should run on Vista? I couldn’t get v3.1 to run.

3.2.17 will run on Vista with Java 8. But I don’t recommend using 3.2.17 at
this point.

I defininitely don’t recommend using Vista—Microsoft ended regular support
for Vista in 2012, and even extended support, which you would have had to
pay for, ended in 2017.


J.

Well, I still use Photo Deluxe (Photoshop 1) [Win95] as well as Photoshop 5 [XP], both of which are very early programs. The latest that will run them is the XP Shell on Vista. I know both programs well, having used them for decades, and in truth very little in the way of prepping art for Vassal requires more - in fact I’ve not found a single reason to use anything (or learn anything) more advanced. As my uncle used to say, “I don’t need a fancy tractor to plow my garden” (he was a farmer).

There aren’t security exploits against tractors.