"Use same boards" can't be undone

I configured a map to “Use same boards” as another map; like so:

Now when I blank out “blue” and ok the change, the change does not take - blue is still there when I return to the map configuration panel. Changing something else at the same time does not seem to help either.

Try VASSAL-3.6.4-SNAPSHOT-dac8765-master: Builds of vassalengine/vassal

Is the problem fixed for you?

1 Like

Yes and no. I can now remove the “Use same boards as this map” map.

However, the fix has unmasked a further problem, one that I have seen before when trying to change the name of a board. That problem is that, after removing the association to another map, the map just displays its background colour. Nothing more, no board image and no At-Start Stack (unless, I found, associated to “[Any]” board rather than a named board, but then I still could not get the board to display its image).

Initially, I was using the same name for the board across several maps. I don’t think this should be a problem, but just in case, I changed the board names to make them map-specific. This made no difference - and I did amend the At-Start stacks to point them to the new board name.

In summary, the change in VASSAL-3.6.4-SNAPSHOT-dac8765-master does appear to have worked but it will not be useful whilst this further problem exists.

As a workaround to both problems, I completely removed the corrupted maps and re-built their definitions. It helps that I was able to copy in and edit definitions from the “master” map.

Mark,

I haven’t been able to reproduce the problem.

Do you still have a copy of the module in the state where ‘Use same boards as this map’ is now blank, but the defined board is not showing?

Thanks,
Brent.

Here’s a module that can show the board problem as I am seeing it:
https://www.dropbox.com/s/x557oje1rbyx4h3/map%20board%20issue.vmod?dl=0

If you open it, join as any player; just select a 3 player game or cancel the prompt (no relevance to this issue).

View the Player Mats;

All maps have boards pointing to the same image and until I started this test, all boards displayed that image. See the image on the Pink, Purple and Yellow hands?

The others show only the map background. These are the actions that caused the maps to disappear:

  1. I renamed Blue’s board from “Hand” to “Blue’s Hand”.
    2 I then made Green use Blue’s board and got the same result.
  2. I made Orange use Pink’s board - same result.

Try the same with another hand; rename the board and see what happens to the image (doesn’t matter if you correct all the stacks for the new board name or not).

It seems that you can rename back to the old board or (unlike my earlier experience) you can remove the associated board and the image is restored. Also, I found I could re-associate the image to the hand, but then the “Use same boards as this map” field gets cleared out.

However, there is still this issue that you can’t rename the board without losing the image.

Mark

There error appears to be at the BoardPicker level, it is being confused by the change. I was able to fix the Blue hand problem by opening the Blue BoardPicker (The ‘Map Boards’ component), clicking on ‘Select Default Board Setup’ and clicking OK.