Using GetProperty with Named Map for SetGlobalProperty

Please help.

I have a [Map Window] called Centauri_Display. In this window, there are [Global Properties] G_GrossEcon, among others.

Now each StarBase in the [Map Window] KnownSpace, contains traits that update the G_GrossEcon for its Empire using a [Set Global Property] that Locate Property starting in the: Named Map
using Name of the map containing property: GetProperty(Empire+Display), where Empire is defined in [Property Sheet] Empire = Centauri, and Display is defined as [Marker] Display = _Display for the unit in question.

Unfortunately, I get an error:
Set Global Property (G_GrossEcon: (g_getActiveEconomy) ::Data transfer: $Economy$ ): Unable to locate Global Property named G_GrossEcon in Named Map GetProperty(Empire+Display)

I have tried various methods like creating a [DP] EmpireMap which sets it using GetProperty(Empire+Display) and then placing Name of the map containing property: EmpireMap for the [SGP] without success.

Any definition of GetProperty() or [SGP] restrictions for Name of the map containing property:?


Very difficult to tell what the problem is without a link to your module and a log file of a situation showing the error.

Where/When can GetProperty(Empire+Display) be utilized. Can I drop this into [DP] EmpireMap new Value: set value directly?

e.g., Empire = Centauri; Display = _Display ==> EmpireMap = Centauri_Display using GetProperty(Empire+Display) in DP?

When I default the [DP] EmpireMap to Centauri_Display and skip its key command, then the [SGP] using Name of the map containing property: $EmpireMap$ resolves as expected.

Got any information regarding GetProperty function?



In Vassal 3.1.18+ you should easily be able to use Named Map:


(assuming $Empire$ resolves correctly for the given map where the unit is: no experience working with Property Sheets).

Under vassal 3.2.0 you could just use the exact same syntax as above. However, if you really want to use GetProperty (no need here, I think), then make sure you use beta3, as there were bugs with GetProperty that Brent fixed sometime between beta 1 and beta 3 (don’t remember if beta 2 had the fix already).

I am working under 3.2.beta3.

Had not tried your suggestion. Will give it a go.

My quick solution was to make a [Marker] HomeMap = Xxxxx Display in a prototype that I add to each piece of that Empire. That way, it is possible to use a create universal prototype to do actions that apply to all pieces.

It did not work as $Empire$ Display though.


Well, yes it does, if I spell properly :unamused: . All is well